November 24, 2017, 11:25
bigger smaller reset 800px Wide width Full width Reset * *

Gildor's Forums

  Homepage Facebook Donate
Welcome, Guest. Please login or register.
Did you miss your activation email?


Login with username, password and session length
« previous next »
Pages: [1] Print
Author Topic: Life Is Strange  (Read 6918 times)
1212aaa
Newbie
*
Posts: 26


View Profile
« on: January 31, 2015, 05:33 »

Life Is Strange is U3 game

Anim and Texture support

StaticMesh and SkeletonMesh no support

plz help
Logged
sn00p
Jr. Member
**
Posts: 72


Oh Wut ?


View Profile WWW
« Reply #1 on: February 01, 2015, 00:50 »

The thread is not that helpful, provide some files for further support, read FAQ http://www.gildor.org/projects/umodel/faq
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6079



View Profile WWW
« Reply #2 on: February 01, 2015, 22:41 »

I've got some files, thanks.
Logged
jiropsnetwork
Newbie
*
Posts: 2


View Profile
« Reply #3 on: February 02, 2015, 03:01 »

UE Viewer crashes when i try to open models in life is strange, i'll try to post as much files as i can tomorrow.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6079



View Profile WWW
« Reply #4 on: February 02, 2015, 11:42 »

The game is fully supported now.
Logged
sn00p
Jr. Member
**
Posts: 72


Oh Wut ?


View Profile WWW
« Reply #5 on: February 02, 2015, 13:00 »

Thanks!
Logged
jiropsnetwork
Newbie
*
Posts: 2


View Profile
« Reply #6 on: February 02, 2015, 17:14 »

Thanks, but i have one problem: I cant find any models or characters whatever i open it only shows box with texture (see screenshot: https://drive.google.com/file/d/0B4Ny59cuBub-eW5PTS1VVFJkRlE/view?usp=sharing )

Please help.

Logged
Gildor
Administrator
Hero Member
*****
Posts: 6079



View Profile WWW
« Reply #7 on: February 02, 2015, 17:36 »

1. Do you know about PageUp/PageDown keys? Check "Navigate" menu visible on your screenshot.
2. There you may also set filter to browse only meshes.
Logged
UncleBob
Newbie
*
Posts: 3


View Profile
« Reply #8 on: April 06, 2016, 03:35 »

I haven't been having luck with static mesh textures in Life is Strange. All of the skeletal meshes texture correctly, all of the MaterialInstanceConstant files are created for all materials, all the textures are exported, but the static meshes don't find their materials. I've run the published version of UModel and built the tool from source. Stepping through the source, for static mesh, the CMeshSection material is always null.

Should this work?

By the way, I find UModel to be a great way to see how games are doing things. Thanks for all the work.

Logged
UncleBob
Newbie
*
Posts: 3


View Profile
« Reply #9 on: April 06, 2016, 05:27 »

I was wrong about the issue. It looks like some static meshes work correctly. I believe it's down to the meshes with all the textures in the same UPK as the mesh are working, and those with textures in other UPK's aren't. I'll dig through the forum some more looking for that.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6079



View Profile WWW
« Reply #10 on: April 06, 2016, 11:01 »

This is the issue from FAQ Smiley
Logged
UncleBob
Newbie
*
Posts: 3


View Profile
« Reply #11 on: April 06, 2016, 21:50 »

I'm sorry if I'm being stupid about this, but I can't figure out what's going on. I've been through the FAQ and everything I could find about missing textures, but don't see what's going on.

I've now found some of the static meshes that seem to have no material, even when the materials do seem to be in the same UPK. Based on the textures, I don't think the materials are anything special. The FAQ does mention that some materials may be set at runtime, so maybe that's happening, but it's happening with a lot of pretty mundane looking static objects. The materials in question are all found and exported as .mat files, they just aren't attached to the meshes.

With the good meshes, in FStaticMeshSection3 operator <<, a good index is read in for S.Mat, and the system is able to find the material instance in the package and return a pointer to the material instance. With the bad meshes, there's a zero sitting in the data for the MaterialInstance index. I don't quite understand the data, so don't know where to look. Is that index some global asset ID that's actually baked into the data on disk, or is there some fixup process that fills that index in somewhere else?

Am I doing something wrong, or are there just a bunch of static meshes that aren't going to come through with materials?

Thanks
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6079



View Profile WWW
« Reply #12 on: April 06, 2016, 22:58 »

In Unreal engine (3 and 4) materials could be assigned with StaticMeshComponent. I think this is why the game have meshes with materials, while the mesh itself is untextured.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS