August 22, 2018, 03:14
bigger smaller reset 800px Wide width Full width Reset * *

Gildor's Forums

  Homepage Facebook Donate
Welcome, Guest. Please login or register.
Did you miss your activation email?


Login with username, password and session length
« previous next »
Pages: 1 [2] 3 Print
Author Topic: Conan Exiles  (Read 3848 times)
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #15 on: August 17, 2017, 20:12 »

Probably they're using some custom texture format - for example this: https://appdevelopermagazine.com/3464/2015/12/27/Granite-for-Unreal-Adds-Advanced-Texture-Streaming-to-Unreal-Engine-4/
Logged
Chrono
Full Member
***
Posts: 104


View Profile
« Reply #16 on: August 17, 2017, 22:37 »


Well thanks for you time, I know you've been super busy lately. Yeah, the files are now protected.
« Last Edit: August 17, 2017, 23:18 by Chrono » Logged
venkman
Sponsor
Newbie
*
Posts: 29


View Profile
« Reply #17 on: April 28, 2018, 01:36 »

Getting this error since the newest game updates...

Memory: bad allocation size 911681360 bytes
appMalloc:size=911681360 (total=1 Mbytes) <- FArray::Empty:1936028277 x 16 <- TArray::Serialize:0/0 <- FPakEntry<< <- FPakVFS::ReadDirectory <- MountVFS <- appRegisterGameFile:c:\Program Files (x86)\Steam\steamapps\common\Conan Exiles/ConanSandbox/Content/Paks/100+crosshairspack.pak <- ScanGameDirectory <- ScanGameDirectory <- ScanGameDirectory <- ScanGameDirectory <- appSetRootDirectory:dir=c:\Program Files (x86)\Steam\steamapps\common\Conan Exiles <- Main:umodel_build=726

Logged
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #18 on: April 28, 2018, 01:43 »

UModel crashes with reading pak file, it seems the file format has been changed.
Logged
venkman
Sponsor
Newbie
*
Posts: 29


View Profile
« Reply #19 on: April 28, 2018, 01:57 »

Anything I can do to help make it work?
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #20 on: April 28, 2018, 13:31 »

No. Probably there's already some third-party tools which extracts Conan pak files, I don't know. I'm very rarely dealing with modified pak file formats. I think the only custom pak file format which is supported by UModel is "Gears of War 4".
Logged
Tagazooka
Newbie
*
Posts: 8


View Profile
« Reply #21 on: June 07, 2018, 07:18 »

Hello, I get these errors when trying to export some assets. Any idea?

ERROR: assertion failed: H.Tag == PACKAGE_FILE_TAG

FCompressedChunkHeader<<:pos=4 <- ReadFullyCompressedHeader <- UnPackage::CreateLoader:RizMods.pak/Characters/humans/meshes/SK_human_female_feet.uasset <- UnPackage::UnPackage:RizMods.pak/Characters/humans/meshes/SK_human_female_feet.uasset, ver=100000/0, game=0 <- UnPackage::LoadPackage:RizMods.pak/Characters/humans/meshes/SK_human_female_feet.uasset <- CUmodelApp::ShowPackageUI <- Main:umodel_build=775
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #22 on: June 07, 2018, 11:27 »

Hello. This is literally the same error as before, it is caused by custom pak file format in this game.
Logged
Tagazooka
Newbie
*
Posts: 8


View Profile
« Reply #23 on: June 07, 2018, 13:54 »

Well I should have told you that I already unpaked the pak files with QuickBMS and thus your tools is stuck on uasset files and not pak files in this case. So I don't know if the error is still related to that previous issue here.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #24 on: June 07, 2018, 14:02 »

Send me a sample, I'll check (just to see what's wrong, not sure if I'll support the game - it's under development yet).
Logged
Tagazooka
Newbie
*
Posts: 8


View Profile
« Reply #25 on: June 08, 2018, 07:58 »

Here is two samples. One for mesh and one for texture. I don't know if it could be different but I put both anyway.

And the game left early access since the 5th May, so I don't think they will do any major changes on files format for a while...

Mesh:
https://yadi.sk/d/C6I6vrEC3XQn9J

Texture:
https://yadi.sk/d/v5znewA_3XQnoA
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #26 on: June 08, 2018, 14:58 »

I've checked these files, they have customized package format. UModel's error message wasn't correct, I've fixed diagnostic message - now UModel will display a message "Wrong tag in package (0). That's what developers did for this game: they inserted 4 zero bytes at the beginning of every file (not just this change, that'd be too easy).

I have a question. Can UModel open pak files from this game, or external tool is always required?
Logged
Tagazooka
Newbie
*
Posts: 8


View Profile
« Reply #27 on: June 09, 2018, 03:44 »

UModel still can't open pak files from Conan Exiles. I'm using a QuickBMS script for that.
Logged
Tagazooka
Newbie
*
Posts: 8


View Profile
« Reply #28 on: June 13, 2018, 16:20 »

Hello,

I tried the last update on UModel and got a different error now when trying to export some files:

ERROR: Wrong tag in package (00000000). Probably the file is encrypted.
FPackageFileSummary<<:Ver=0/0 <- UnPackage::UnPackage:RizMods.pak/Characters/humans/meshes/SK_human_female_feet.uasset, ver=100000/0, game=0 <- UnPackage::LoadPackage:RizMods.pak/Characters/humans/meshes/SK_human_female_feet.uasset <- CUmodelApp::ShowPackageUI <- Main:umodel_build=777

...

But still that same error when trying to open a pak files directly:

WARNING: Pak "D:\Downloads\Jeux\ConanMods\UModel/RizMods.pak" has strange mount point "C:/Users/Riz/AppData/Local/ConanSandbox/Saved/Mods/CookedMods/RizMods/", mounting to root
ERROR: Memory: bad allocation size -685369776 bytes
appMalloc:size=-685369776 (total=0 Mbytes) <- FArray::Empty:1836212581 x 16 <- TArray::Serialize:0/0 <- FPakEntry<< <- FPakVFS::ReadDirectory <- MountVFS <- appRegisterGameFile:D:\Downloads\Jeux\ConanMods\UModel/RizMods.pak <- ScanGameDirectory <- appSetRootDirectory:dir=D:\Downloads\Jeux\ConanMods\UModel <- Main:umodel_build=777
Logged
Gildor
Administrator
Hero Member
*****
Posts: 6728



View Profile WWW
« Reply #29 on: June 13, 2018, 16:42 »

Yes, I mentioned that:
UModel's error message wasn't correct, I've fixed diagnostic message - now UModel will display a message "Wrong tag in package (0)".
Logged
Pages: 1 [2] 3 Print 
« previous next »
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS