Gildor's Forums

Author Topic: Fractured Space  (Read 2273 times)
FusionSticc
Newbie
*
Posts: 9


View Profile
Fractured Space
« on: May 08, 2017, 09:43 »

Hello all. I'm relatively new here, and I have encountered a small but major problem with the game Fractured Space, a F2P game. While extracting the ships (They're in folders M00-02)
There are several errors with the materials/textures. 90% of the assets are perfectly fine, however, these textures are sometimes ship textures and will cause the ship to look relatively weird (looks green, gray textures). In the console it gives me this error

Loading Material3 M_WindowLights from package /spacegame/Content/Materials/Ships/M_WindowLights.uasset
WARNING: StructProperty "UMaterial3::BaseColor" was not found
WARNING: StructProperty "UMaterial3::Specular" was not found
WARNING: ByteProperty "UMaterial3::ShadingModel" was not found
WARNING: BoolProperty "UMaterial3::bCanMaskedBeAssumedOpaque" was not found
WARNING: StructProperty "UMaterial3::StateId" was not found

(This is an example of one of the other material with these errors)

I was thinking that it's mainly because UE4 support is still being improved on, however I just wanted to make sure if this is a normal bug/error right now.
Game engine version is 4.14.3
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7821



View Profile WWW
Re: Fractured Space
« Reply #1 on: May 08, 2017, 10:14 »

Hi. Welcome here.

Materials could appear weird in UModel. Unreal materials could be very complex, and UModel can't handle them correctly. You may see some red-green-blue mask used to map different material layers into a single material. UModel can show more or less correctly only very simple materials.
Regarding "errors" listed in your post - they are not errors at all. These are information messages which are useful (for me) only in some particular cases.

I see the game is not in "early access", so I'll add it to the compatibility table.
Logged
FusionSticc
Newbie
*
Posts: 9


View Profile
Re: Fractured Space
« Reply #2 on: May 09, 2017, 02:31 »

Ah! I see! Thanks!
Logged
masterzh7
Newbie
*
Posts: 2


View Profile
Re: Fractured Space
« Reply #3 on: February 19, 2018, 22:20 »

Greatly apologize for necro-post Sad i would really love to know how above person extracted the ships/assets as all of the content is AES encrypted.I assume they added the protection some time after ? Or is there any workaround ?

thanks in advance for any clues and apologize for necropost
Logged
masterzh7
Newbie
*
Posts: 2


View Profile
Re: Fractured Space
« Reply #4 on: February 24, 2018, 18:43 »

Just a small example... already got ships and textures but ripper UVs mapping dont make much sense to me. Sad I tried all the suggested (usual UV pairs) without any luck.
Logged
Dire_Venom
Newbie
*
Posts: 2


View Profile
Re: Fractured Space
« Reply #5 on: November 17, 2019, 13:13 »

Just a small example... already got ships and textures but ripper UVs mapping dont make much sense to me. Sad I tried all the suggested (usual UV pairs) without any luck.


Bit of a necro, but I can help if you link the models.
I've been trying to put them together too, however the pak encryption has been frustrating.
Logged
Fastfood9000
Newbie
*
Posts: 1


View Profile
Help extracting assets from "Fractured Space"
« Reply #6 on: October 16, 2020, 09:13 »

Hello, I am currently attempting to rip assets from the game "Fractured Space". The game paks are AES encrypted BUT I already got the key for that so that is not my issue. My issue is that no matter what assets I try to rip it gives me an error along the lines of
Quote
ERROR: zlib uncompress(390,804) returned -3
appDecompress: CompSize=390 UncompSize=804 Flags=0x1 Bytes=1E28 <- SerializeCompressed <- FPakFile::Serialize: file=/Game/Movies/V_LastStandAnimation_Video.uasset <- FArchive::ByteOrderSerialize <- UnPackage::CreateLoader: /Game/Movies/V_LastStandAnimation_Video.uasset <- UnPackage::UnPackage: /Game/Movies/V_LastStandAnimation_Video.uasset, ver=100000/0, game=0 <- UnPackage::LoadPackage(info): /Game/Movies/V_LastStandAnimation_Video.uasset <- CUmodelApp::ShowPackageUI <- Main: umodel_build=1401

The 2 numbers in the parenthesis change but it always gives this error. This is literally the only game on my PC that I have this issue with, all my other unreal games work fine with umodel. I already tried the thing in the FAQ where it says to selec LZO in the startup options. I also uninstalled and reinstalled umodel like 3 times. I even moved the game and umodel to another drive to no avail. The thing is too yeah its that I was talking to another user on reddit about this because he helped me get the AES key and he did the exact same things I am doing and it just worked for him so as of now I am at a loss.
« Last Edit: October 16, 2020, 09:20 by Gildor » Logged
spiritovod
Full Member
***
Posts: 221


View Profile
Re: Fractured Space
« Reply #7 on: October 16, 2020, 19:01 »

Latest game client (before the game was shut down) is using 4.19. Meshes and textures are working fine with the latest umodel build (1405 at the moment). Some materials are custom and it seems the game is using non-native animations via Live Link plugin - not sure how it works though. I could barely find two skeletal meshes and only one was linked with native animation file. Can't imagine how the error above was produced, since umodel doesn't support viewing and exporting of such assets.

AES key: in the same place as usual (link)
« Last Edit: October 17, 2020, 18:14 by spiritovod » Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS