Gildor's Forums

Author Topic: Darksiders Genesis  (Read 473 times)
laharl99999
Newbie
*
Posts: 4


View Profile
Darksiders Genesis
« on: December 05, 2019, 23:34 »

Hello,
I was able to open Darksiders genesis, export some assets with 4.23 version but there are sometimes errors so I guess I didn't use the right version.
Anyone knows what is the version ?

Version tested :
4.14 crash when opening some models.
4.15 crash
4.16 crash
4.17 crash

4.22 seems to be working except that the assets in the viewer are too bright.
Thank you
« Last Edit: December 06, 2019, 00:23 by laharl99999 » Logged
san
Silver Sponsor
Full Member
**
Posts: 96


View Profile
Re: Darksiders Genesis
« Reply #1 on: December 05, 2019, 23:50 »

Game uses 4.22 version. Everything works, static, skeletal, animations and textures

Hello,
I was able to open Darksiders genesis, export some assets with 4.23 version but there are sometimes errors so I guess I didn't use the right version.
Anyone knows what is the version ?

Version tested :
4.14 crash when opening some models.
4.15 crash
4.16 crash
4.17 crash

Thank you
Logged
san
Silver Sponsor
Full Member
**
Posts: 96


View Profile
Re: Darksiders Genesis
« Reply #2 on: December 05, 2019, 23:54 »

Maybe this will be useful to ppl who are not sure about engine version..rather than trying out random version numbers you can

1. Look for *Shipping.exe file in your game installation folder, usually this will be in Binaries/Win64
2. Right click and go to 'Details' tab. The File version provided there is the Unreal Engine version :-)

Cheers
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7815



View Profile WWW
Re: Darksiders Genesis
« Reply #3 on: December 05, 2019, 23:57 »

1. Look for *Shipping.exe file in your game installation folder, usually this will be in Binaries/Win64
2. Right click and go to 'Details' tab. The File version provided there is the Unreal Engine version :-)
I'll add this tip to "BOARD RULES". May be someone will read it Smiley Personally myself I'm always trying all versions, it doesn't appear to me as something very hard.
Logged
laharl99999
Newbie
*
Posts: 4


View Profile
Re: Darksiders Genesis
« Reply #4 on: December 06, 2019, 00:26 »

Maybe this will be useful to ppl who are not sure about engine version..rather than trying out random version numbers you can

1. Look for *Shipping.exe file in your game installation folder, usually this will be in Binaries/Win64
2. Right click and go to 'Details' tab. The File version provided there is the Unreal Engine version :-)

Cheers
Looking at UnrealCEFSubProcess.exe I find 4.18.0-0+UE4
However using 4.18 crash on some models while 4.22 seems to work.
« Last Edit: December 06, 2019, 00:28 by laharl99999 » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7815



View Profile WWW
Re: Darksiders Genesis
« Reply #5 on: December 06, 2019, 00:31 »

"CEF" is "Chromium Embedded Framework", not the engine. It might be not compiled, or even missing in the game - it is not used for most cases.
Logged
san
Silver Sponsor
Full Member
**
Posts: 96


View Profile
Re: Darksiders Genesis
« Reply #6 on: December 06, 2019, 02:04 »

Everything is working fine with 4.22......for objects appearing too bright, you need to change the material setting, press Ctrl+G

it's all explained in the YouTube tutorial posted by Gildor :-)

4.22 seems to be working except that the assets in the viewer are too bright.
Thank you
Logged
laharl99999
Newbie
*
Posts: 4


View Profile
Re: Darksiders Genesis
« Reply #7 on: December 06, 2019, 11:40 »

Yep 4.22.2 seems to be the UE4 version used.
Everything seems to work.
I still find strange that the chaos form is using the mask texture (glow texture ?)  instead of the red texture


Anyone found the mesh of the glide wings (shadow flight black wings when you double jump)?I looked into VFX but couldn't find it.
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS