Gildor's Forums

Author Topic: Backface Culling  (Read 8448 times)
Almondega
Newbie
*
Posts: 10



View Profile
Backface Culling
« on: September 02, 2012, 18:11 »

Hi everyone.

I'm having a problem importing UE Viewer exported models into ActorX with 3ds max 2012, as some backfaced meshes shows up correctly in UE Viewer, but when imported into 3ds max, they get backfaced culled. A sample is attached in this post.

Am I missing some export or import configuration to get the mesh imported into 3ds max, without the culling?

Thanks.

[вложение удалено Администратором]
Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 358


View Profile
Re: Backface Culling
« Reply #1 on: September 02, 2012, 20:30 »

that I believe is purely a max viewport you are having. I think all textures are non-culled in viewport untill you tell it to be 2 sided
Logged
Almondega
Newbie
*
Posts: 10



View Profile
Re: Backface Culling
« Reply #2 on: September 02, 2012, 20:34 »

that I believe is purely a max viewport you are having. I think all textures are non-culled in viewport untill you tell it to be 2 sided

The problem is, even when that model is exported from 3ds max (to FBX for example), that mesh will be backface culled.
So I guess this isn't just a 3ds viewport configuration Undecided
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7921



View Profile WWW
Re: Backface Culling
« Reply #3 on: September 03, 2012, 08:15 »

pixellegolas was right - you should set "two sided" flag for corresponding materials.
Logged
Almondega
Newbie
*
Posts: 10



View Profile
Re: Backface Culling
« Reply #4 on: September 03, 2012, 19:51 »

pixellegolas was right - you should set "two sided" flag for corresponding materials.

Hi Gildor.

I had set "two sided" flag on for that material, and indeed the 3ds max became to show the mesh properly, without the backface culling.

But when I exported the model to FBX to use it in the Unity 3D engine, the mesh became backface culled again.

Maybe this is a problem regarding 3ds max + FBX + Unity, not an ActorX issue.

Thanks for the replies.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7921



View Profile WWW
Re: Backface Culling
« Reply #5 on: September 03, 2012, 19:59 »

Check Unity documentation. It have two-sided materials too.
http://docs.unity3d.com/Documentation/Components/SL-CullAndDepth.html
Logged
Almondega
Newbie
*
Posts: 10



View Profile
Re: Backface Culling
« Reply #6 on: September 03, 2012, 20:16 »

Check Unity documentation. It have two-sided materials too.
http://docs.unity3d.com/Documentation/Components/SL-CullAndDepth.html

Thanks for this link! I will try the Cull Off shader to solve this problem.

Best regards.
Almondega.
Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 358


View Profile
Re: Backface Culling
« Reply #7 on: September 04, 2012, 12:19 »

Exactly, there are special shaders that work with diffuse+alpha+backface culling. It is not a standard material/shader. In the wiki there is a shader that does this. Strange that it is not a standard because you very often need this. But I think this combo takes alot more system memory in games also
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7921



View Profile WWW
Re: Backface Culling
« Reply #8 on: September 04, 2012, 12:30 »

It's quite easy to create new shader in Unity by copying (and renaming) one of predefined shaders and adding required lines to code.
Logged
Almondega
Newbie
*
Posts: 10



View Profile
Re: Backface Culling
« Reply #9 on: September 05, 2012, 04:07 »

Check this out!

I did just like you said Gildor, took the default diffuse shader, and added the Cull Off thing Wink

Working like a charm, thank you very much!

[вложение удалено Администратором]
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS