Gildor's Forums

Poll
Question: Are your TERA animations loading properly in 3ds Max?
Everything works as I expected! - 2 (28.6%)
I can import everything I need, but some things are a little off. - 3 (42.9%)
I can't get some things to load. Please help!!! - 0 (0%)
Nothing works. What have I been doing my entire life? - 1 (14.3%)
I have no idea what this entire thread is even about. - 1 (14.3%)
Total Voters: 7

Author Topic: TERA Online - "Dummy_Root" does not Animate? - Flailing Arms & Legs!?  (Read 11009 times)
xbeton0L
Sponsor
Newbie
*
Posts: 7


View Profile
TERA Online - "Dummy_Root" does not Animate? - Flailing Arms & Legs!?
« on: June 09, 2013, 14:02 »

Hello there,

Firstly I must say thank you Gildor for the amazing software you've created! Keep doing what needs to be done, and I'll keep doing my best to learn too.

Now, I've been experimenting with putting TERA Online's models together in 3ds Max, using the ActorX Importer with endearing success, and while I'm able to do what I want to with the models (such as combining the hair, head, body, arms and legs models together) there seems to be some kind of overhead animation offset which causes the animations to appear off.

If I load up one of the animations from the PSA, the biped rig does what it should be doing, however from what I can tell it seems that one of the bones which controls the root does not animate. Imagine someone flailing their arms and legs while sitting in a chair (which is supposed to be a simple standing animation). That's what the animations look like. Of course deducting from what I see, it seems that the bone called "Dummy_root" needs to be attached to something.

In my notes I've noticed that some of the bones in the head (face) and hair models are supposed to align with parts of the biped rig, their names starting with "Dummy_" and they can easily be aligned to the rest of the character's body. Simple orientation and position constraints are enough to handle this. It just requires a good eye.

However, in doing so, I can't help but think that the body is also parented to some other object. If the head and hair have "dummy_" roots, and those bones align to corresponding bones within the body, then does that mean that the body's root bone ("Dummy_root") also needs to align to some other object in order to animate properly? And if so, what?

Would anyone happen to have a more extensive idea of what I'm talking about? Are there other objects I should load through ActorX? Not just the hair, head and body, but something that the body itself would attach to?

I am grateful to anyone who replies. Thanks! ^^
« Last Edit: June 09, 2013, 14:15 by xbeton0L » Logged
deant02
Newbie
*
Posts: 13


View Profile
Re: TERA Online - "Dummy_Root" does not Animate? - Flailing Arms & Legs!?
« Reply #1 on: July 04, 2013, 01:19 »

try this tutorial, worked for me.
http://www.youtube.com/watch?v=U2MZCeDXKrk
Logged
RIMBROS
Newbie
*
Posts: 21


View Profile
Re: TERA Online - "Dummy_Root" does not Animate? - Flailing Arms & Legs!?
« Reply #2 on: September 22, 2013, 21:36 »

I have a question why in some Ride pets, atm import with ActorX looks like floating.

Logged
Gildor
Administrator
Hero Member
*****
Posts: 7932



View Profile WWW
Re: TERA Online - "Dummy_Root" does not Animate? - Flailing Arms & Legs!?
« Reply #3 on: September 22, 2013, 23:29 »

Play with "translation mode" settings.
Logged
RIMBROS
Newbie
*
Posts: 21


View Profile
Re: TERA Online - "Dummy_Root" does not Animate? - Flailing Arms & Legs!?
« Reply #4 on: September 23, 2013, 11:55 »

Thanks bro, works perfect with Force Animset Translation. Grin
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS