Gildor's Forums

Author Topic: Thief 2014  (Read 13906 times)
MissSushine
Newbie
*
Posts: 1


View Profile
Re: Thief 2014
« Reply #15 on: July 23, 2015, 15:02 »

It would pull out patterns and maybe even objects but in the version I own Pc of steam are not been able to locate the files that interest me ... can someone kindly direct me?  Embarrassed
Logged
axelfond
Newbie
*
Posts: 8


View Profile
Re: Thief 2014
« Reply #16 on: September 21, 2017, 09:42 »

Sorry to Necro this thread. I have been unable to get 90% of textures from this game. Any ideas?
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7974



View Profile WWW
Re: Thief 2014
« Reply #17 on: September 21, 2017, 11:29 »

Sorry to Necro this thread. I have been unable to get 90% of textures from this game. Any ideas?
No idea. What happens?
Logged
axelfond
Newbie
*
Posts: 8


View Profile
Re: Thief 2014
« Reply #18 on: October 02, 2017, 03:45 »

When viewing the models, they all load perfectly but the textures are never applied or rendered except in rare cases.

I know you put a lot of effort to get the textures working with some weird custom compression.

Am I doing something wrong?

(I am reinstalling the game and will check if any interesting errors pop up)
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7974



View Profile WWW
Re: Thief 2014
« Reply #19 on: October 02, 2017, 10:36 »

I think you're doing everything correctly. This is a common problem, which is even listed in FAQ.
Logged
axelfond
Newbie
*
Posts: 8


View Profile
Re: Thief 2014
« Reply #20 on: October 02, 2017, 16:21 »

Quote
Meshes in a viewer are not textured. What's wrong?

There are a few variants of answer:

    umodel is unable to find some package containing materials - check umodel logs
    mesh is not textured, materials are assigned by the game in runtime or in MeshComponent object (UE3)
    material is too complex for umodel, so it is replaced with "default texture"
    this is a variant of (1) - you're trying to start umodel with a wrong game path. For example: UE2 game usually has "Textures", "Animations" and some other directories. If you'll start umodel from the "Amimations" directory, umodel will not file textures. You should start it from the parent directory - common for the "Animations" and "Textures".



So are the textures there but just it's too complicated for umodel to render??
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7974



View Profile WWW
Re: Thief 2014
« Reply #21 on: October 02, 2017, 19:37 »

Yes.
Logged
axelfond
Newbie
*
Posts: 8


View Profile
Re: Thief 2014
« Reply #22 on: October 03, 2017, 11:43 »

I tried exporting the mesh, got no texture only the .pskx mesh..

I come into the game from Root. Any Ideas? If I could just get the diffuse / normal - I'd be happy.
You put a ton of effort to get these textures working. Did something happen like an update?
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7974



View Profile WWW
Re: Thief 2014
« Reply #23 on: October 03, 2017, 11:50 »

Press "M" key when viewing a mesh, you'll see names of materials. If there will be NAMES, and you see no materials - this means materials are too complex for being displayed.

If you'll see 'None' instead of the material's name - this means that materials are not assigned for some reason. Possible reasons for missing materials:

1. Most common problem for users who follows somebody-else's instructions. When user copies a package somewhere from the game folder (for viewing in umodel), most likely there will be some other packages which won't be copied, but which are needed. For example, these packages may contain materials or textures. UModel won't find them, and won't display its content. However it's easy to notice such problem if you'll look at log: you'll see a kind of "unable to find package" message there.

2. Material is not assigned to a mesh. This may happen, because mesh is not only the place where material could be assigned. Material could be assigned by script, or in mesh component (for UE4 - in blueprint).

3. There could be some incompatibility of UModel with this game, so UModel won't read the list of materials. In this case usually ALL meshes appears untextured.
Logged
axelfond
Newbie
*
Posts: 8


View Profile
Re: Thief 2014
« Reply #24 on: October 05, 2017, 17:08 »


So when I hit 'M' the textures come out as Null. Many of these meshes have multiple sections which I assume are just the different UVMaps.

1. I am coming into a full install of the game off Steam, so I shouldn't be missing anything.

2. This is possible for sure.

3. Some models occasionally load their materials (The vast vast majority don't)

No way to solve that I guess.. I generally like to view models fully rendered than export as I see fit, sounds like I'll need to track down the Textures that go with each mesh I'm interested in. Any easy way to look that up?  Tongue
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7974



View Profile WWW
Re: Thief 2014
« Reply #25 on: October 05, 2017, 20:34 »

Any easy way to look that up?  Tongue
I don't think so.
Logged
axelfond
Newbie
*
Posts: 8


View Profile
Re: Thief 2014
« Reply #26 on: October 07, 2017, 08:41 »

Thanks Gildor.  Tongue
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS