Gildor's Forums

Author Topic: Unreal Engine 4 support  (Read 55647 times)
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Unreal Engine 4 support
« on: January 11, 2015, 20:05 »

Current status of Unreal engine 4 support (updated 30.05.2020)

  • Supported versions from 4.0 to 4.25. Older versions (before 4.0 release) could be supported only if packages has version information inside, however there's just a few games which used it.
  • You must explicitly specify UE4 version to be able to load packages - there's no possibility to detect package version. If unversioned package will be found, UModel will prompt user for selecting a suitable UE4 version.
  • Supported all asset types: SkeletalMesh, StaticMesh, Texture, Material, Animation, SoundWave.
  • To export animations from any UE4 game, you must follow exact workflow from tutorial mentioned below.
  • OPUS sounds are exported into "UE4OPUS" file format. It is "something special".
  • Editor packages did work before, but starting with probably 4.22 something has been changed, and I didn't fix the issues yet.


If you want to see my plans regarding to UE4 support (and for anything else) - please visit my UE Viewer Trello board.



For usage information and tutorials, or before asking any questions, please watch videos on UModel's youtube channel.



To understand how to work with animations, you should watch this video (it is a part of playlist above).



Starting from build 751 animaiton workflow has been simplified

« Last Edit: May 30, 2020, 14:07 by Gildor » Logged
stonecoldnuts
Silver Sponsor
Newbie
**
Posts: 37


View Profile
Re: Unreal Engine 4 support
« Reply #1 on: January 15, 2015, 15:17 »

Well done, Gildor!  Cheesy
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #2 on: January 18, 2015, 17:13 »

Now UModel has SkeletalMesh support. If you like, see some screenshots on facebook page:
https://www.facebook.com/ue.viewer

« Last Edit: January 06, 2017, 09:57 by Gildor » Logged
jmgg
Newbie
*
Posts: 14


View Profile
Re: Unreal Engine 4 support
« Reply #3 on: January 29, 2015, 01:43 »

In this game there is a pak file. How can I use umodel for open this file? thanks!
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #4 on: January 29, 2015, 01:45 »

Just point umodel's path to directory with pak file(s). And don't forget to set game to "Unreal engine 4.4" with UI, or use -game=ue4.4 if you use command line.
Logged
jmgg
Newbie
*
Posts: 14


View Profile
Re: Unreal Engine 4 support
« Reply #5 on: January 29, 2015, 01:55 »

Thanks Gildor! is posible make a batch process?
« Last Edit: January 29, 2015, 02:03 by jmgg » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #6 on: January 29, 2015, 01:57 »

What's "re pag" and "av pag"?
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #7 on: January 29, 2015, 02:00 »

Ah, ok. Found in google - PgUp/PgDn is Spanish Smiley
These keys can't work because each package contains only 1 object. You may load multiple objects with selecting them with mouse (ordinary multi-select, like in Explorer).
Batch export works, simply select multiple files in "package selector" and press "export".
Logged
jmgg
Newbie
*
Posts: 14


View Profile
Re: Unreal Engine 4 support
« Reply #8 on: January 29, 2015, 02:23 »

I get this error when I try import a model:
Package "WarmachineGame/Content/Characters/Cygnar/Warcasters/AllisonJakes/Mesh/AllisonJakes_Dagger.uasset": wrong import index 131071
UnPackage::CreateImport:WarmachineGame/Content/Characters/Cygnar/Warcasters/AllisonJakes/Mesh/AllisonJakes_Dagger.uasset:131071 <- UnPackage::SerializeUObject <- TArray::Serialize:0/82536 <- USkeletalMesh3::Serialize <- LoadObject:SkeletalMesh3'AllisonJakes_Dagger.AllisonJakes_Dagger', pos=B1D, ver=385/0, game=10005 <- UObject::EndLoad <- LoadWholePackage:AllisonJakes_Dagger <- Main:umodel_version=315
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #9 on: January 29, 2015, 02:29 »

Your UModel will load only textures. Please disable skeletal and static mesh loading, or use newer version of umodel.

Seriously, your version is from December 5th  Grin
Logged
jmgg
Newbie
*
Posts: 14


View Profile
Re: Unreal Engine 4 support
« Reply #10 on: January 29, 2015, 02:55 »

Ok. Now it works!! thanks Wink
Logged
Brigadeiro
Newbie
*
Posts: 6


View Profile
Re: Unreal Engine 4 support
« Reply #11 on: February 23, 2015, 14:21 »

If I try to extract Models from WC (http://thechroniclesofalexstrasza.com), i get this Error messages (i use the latest Version):

ERROR: Unversioned UE4 packages are not supported. Please override game using UI or command line.
SerializePackageFileSummary4 <- FPackageFileSummary<<:Ver=0/0 <- UnPackage::UnPackage:OST_Game/Content/WC/Characters/DraeneiFemaleHD/CassandraHD.uasset, ver=0/0, game=10000 <- UnPackage::LoadPackage:OST_Game/Content/WC/Characters/DraeneiFemaleHD/CassandraHD.uasset <- Main:umodel_version=334

ERROR: Unversioned UE4 packages are not supported. Please override game using UI or command line.
SerializePackageFileSummary4 <- FPackageFileSummary<<:Ver=0/0 <- UnPackage::UnPackage:OST_Game/Content/WC/Furniture/Stormwind_Graves_01.uasset, ver=0/0, game=10000 <- UnPackage::LoadPackage:OST_Game/Content/WC/Furniture/Stormwind_Graves_01.uasset <- Main:umodel_version=334

ERROR: Unversioned UE4 packages are not supported. Please override game using UI or command line.
SerializePackageFileSummary4 <- FPackageFileSummary<<:Ver=0/0 <- UnPackage::UnPackage:OST_Game/Content/WC/Characters/DraeneiFemaleHD/DaemiaHDL.uasset, ver=0/0, game=10000 <- UnPackage::LoadPackage:OST_Game/Content/WC/Characters/DraeneiFemaleHD/DaemiaHDL.uasset <- Main:umodel_version=334

What can I do?
I have also another question: Could i export the .uasset files from a UE4 Game? I could import them better in UE4 if I don't want to modify them.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #12 on: February 23, 2015, 14:23 »

Did you read an error message?
ERROR: Unversioned UE4 packages are not supported. Please override game using UI or command line.

You should specify which UE4 version was used for this game.
Logged
Brigadeiro
Newbie
*
Posts: 6


View Profile
Re: Unreal Engine 4 support
« Reply #13 on: February 26, 2015, 11:50 »

It was 4.6.1
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7925



View Profile WWW
Re: Unreal Engine 4 support
« Reply #14 on: February 26, 2015, 11:56 »

So, umodel works with this game now?
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS