Gildor's Forums

Author Topic: [UE4] Blade & Soul Complete  (Read 7883 times)
ragova1310
Newbie
*
Posts: 2


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #30 on: July 24, 2021, 16:48 »

I'm posting here the full paks for the new B&S frontline test,
UE 4.25
Key still the same: 0x383246F1AC0811FC28CE171F3E63C9C9ABCEE137FF1CF1EF4A6B8A47BAB5AA7C

Remember to update umodel~

https://www.mediafire.com/file/0vzxa32u8vb1ysc/Paks.7z/file

Link will be up for 1 month only so... get it 'till it last~

Link doesnt' work. Can you upload it? Thanks  grin
Logged
SearchForHype
Newbie
*
Posts: 13


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #31 on: September 14, 2021, 15:08 »

Any idea why the files on the new UE4 Client on NC Soft don't scan?
Logged
WollieWoltaz
Full Member
***
Posts: 197


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #32 on: September 15, 2021, 00:21 »

Maybe you inserted the wrong AES key?
This is the right one: 0xD2E5F7F94E625EFE2726B5360C1039CE7CB9ABB760A94F37BB15A6DC08741656
Logged
gamer19771356
Newbie
*
Posts: 6


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #33 on: September 25, 2021, 20:52 »

Hi the key doesn't work for me
Logged
WollieWoltaz
Full Member
***
Posts: 197


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #34 on: September 25, 2021, 21:01 »

It does for me. Are you using the latest Umodel version?
Logged
gamer19771356
Newbie
*
Posts: 6


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #35 on: September 26, 2021, 08:09 »

yes i use the last version umodel
Logged
gamer19771356
Newbie
*
Posts: 6


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #36 on: September 26, 2021, 08:11 »

you have exe file game
Logged
drogan
Sponsor
Newbie
*
Posts: 1


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #37 on: October 04, 2021, 02:51 »

Hey, I'm currently trying to export animations from the paks and I've tried exporting to both ActorX (psa) and glTF 2.0.

For PSA files, when i export this: /Game/bns/Package/00006760/Skill_Standard_JinF_Animset/SW_A_Standard_Skl_blocking_Looping_Move.uasset

I get this error:
assertion failed: strlen(*Anim->TrackBoneNames) < sizeof(B.Name)

ExportObject:Skeleton'00001_JinM_Skeleton' <- ExportObjects <- ExportPackages <- CUmodelApp::ShowPackageUI <- Main:umodel_build=1183

Gildor explained the issue here.

And for glTF, nothing gets exported. This is the message displayed in the console:
WARNING: ObjectProperty "UAnimSequence4::Animset" was not found
WARNING: NameProperty "UAnimSequence4::SequenceName" was not found
WARNING: BoolProperty "UAnimSequence4::bServiced" was not found
Loading Skeleton JinF_001_Skeleton from package /Game/bns/Package/00002691/JinF_001/JinF_001_Skeleton.uasset
Exporting objects ...
ERROR: glTF animation could be exported from mesh viewer only.
Memory: allocated 219153150 bytes in 645586 blocks
Exported 0/0 objects in 0.4 sec


It fails every time, for all animations, after the Loading Skeleton JinF_001_Skeleton line.

What other options do I have for exporting animations?  undecided

ERROR: glTF animation could be exported from mesh viewer only.
Did you read that? If you don't know what does this mean, just watch my recent youtube video.

Hi, sorry to bring this up again. I am experiencing the same problem - can't export some animations to .psa. Could you please tell me what was the answer to the problem or what the solution is?

Is this the youtube video that you were mentioning? https://www.youtube.com/watch?v=OJUTXF8ZQEw
I watched it, but wasn't much wiser after watching it. Thank you in advance.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7958



View Profile WWW
Re: [UE4] Blade & Soul Complete
« Reply #38 on: October 27, 2021, 10:08 »

Fixed.
Logged
Dreadfred
Sponsor
Newbie
*
Posts: 32


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #39 on: November 20, 2021, 23:45 »

Hello, when extracted the character textures have blocks of stripped out 4x4 pixels (no problem in UE viewer).
« Last Edit: November 20, 2021, 23:53 by Dreadfred » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7958



View Profile WWW
Re: [UE4] Blade & Soul Complete
« Reply #40 on: November 20, 2021, 23:48 »

Hi. Probably these blocks are transparent (has something encoded into texture's alpha channel), so your image viewer just ignores any color of pixels when displaying it.
Logged
Dreadfred
Sponsor
Newbie
*
Posts: 32


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #41 on: November 21, 2021, 02:40 »

Hi Gildor, Textures from the 4.22 client export good but with 4.25 there's a bunch of textures with black blocks (never smaller than 4x4pixels). They always show good with Umodel.
« Last Edit: November 21, 2021, 20:39 by Dreadfred » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7958



View Profile WWW
Re: [UE4] Blade & Soul Complete
« Reply #42 on: November 21, 2021, 02:46 »

I don't know what to look at on your screenshots.
Still may be alpha channel. This is DXT5 texture format, which has alpha.
How the mesh appears in a viewer - is it displayed correctly?
Try exporting to dds format, it will be exported "as is", with no changes.
Logged
Dreadfred
Sponsor
Newbie
*
Posts: 32


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #43 on: November 21, 2021, 03:05 »

Thanks Gildor dds format did the trick.
Maybe use to some one =)
 
« Last Edit: January 31, 2022, 00:21 by Dreadfred » Logged
stephan
Newbie
*
Posts: 5


View Profile
Re: [UE4] Blade & Soul Complete
« Reply #44 on: December 10, 2021, 15:21 »

Everything's fine, but the texture in many models seems to not be path correctly to the model or something else. When i open model in 3ds max i can put texture to the model, but with many models it will cost a looot of time to do it.  Is it something we can fix or it's nothing to be done?

https://i.imgur.com/7Hxm68D.png

Regards
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS