Gildor's Forums

Author Topic: Build Fail Errors  (Read 295 times)
vvspers
Newbie
*
Posts: 7


View Profile
Build Fail Errors
« on: March 20, 2021, 17:16 »

When I try to build this is the errors it spits out.

  vc32tools: line 60: cat: command not found
  Visual Studio Community 2019 toolset 142 () [32 bit] found at "C:\Program Files (x86)\Microsoft Visual Studio\2019\Community" ...
  vc32tools: line 173: ls: command not found
  build.sh: Unreal/Shaders/make.pl: /usr/bin/perl: bad interpreter: No such file or directory
  build.sh: line 114: mkdir: command not found
  build.sh: line 128: ./obj/umodel-vc-win32-debug.mak: No such file or directory
  ERROR: makefile "./obj/umodel-vc-win32-debug.mak" is not found
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7976



View Profile WWW
Re: Build Fail Errors
« Reply #1 on: March 20, 2021, 17:20 »

I think you didn't properly set up the BuildTools.
Logged
vvspers
Newbie
*
Posts: 7


View Profile
Re: Build Fail Errors
« Reply #2 on: March 20, 2021, 17:28 »

I have C:\BuildTools\bin as the system variable do I also need it under user variable and does it require a specific name?
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7976



View Profile WWW
Re: Build Fail Errors
« Reply #3 on: March 20, 2021, 17:30 »

Try running "bash", "perl" and "ls" from the command line, see if all works. I see that you can run "bash", but bash itself can't see any other command located in C:\BuildTools\bin.
Logged
vvspers
Newbie
*
Posts: 7


View Profile
Re: Build Fail Errors
« Reply #4 on: March 20, 2021, 17:38 »

I am able to get bash and ls to run via command line. Perl seems to do nothing.
Logged
vvspers
Newbie
*
Posts: 7


View Profile
Re: Build Fail Errors
« Reply #5 on: March 20, 2021, 17:41 »

Logged
vvspers
Newbie
*
Posts: 7


View Profile
Re: Build Fail Errors
« Reply #6 on: March 20, 2021, 17:47 »

and here is when i the files directly in the UEViewer folder.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7976



View Profile WWW
Re: Build Fail Errors
« Reply #7 on: March 20, 2021, 18:03 »

"ls" etc should work from ANY directory if you put C:\BuildTools\bin into your PATH (either as system global, or in build.bat as was suggested in readme.md).
Logged
vvspers
Newbie
*
Posts: 7


View Profile
Re: Build Fail Errors
« Reply #8 on: March 20, 2021, 18:11 »

ls is working in any directory but I still spit out the same errors on build also tried with the bat file as suggested.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7976



View Profile WWW
Re: Build Fail Errors
« Reply #9 on: March 20, 2021, 19:10 »

Try moving BuildTools to the top of the path chain. Probably you have another bash.exe on the system, and it doesn't know about the BuildTools location. If won't help, I have no idea what's wrong then.
Logged
vvspers
Newbie
*
Posts: 7


View Profile
Re: Build Fail Errors
« Reply #10 on: March 20, 2021, 19:15 »

I was able to get it working something must have been corrupted on download because I started with 2 fresh downloads and it ended up working thanks!
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS