Gildor's Forums

Author Topic: Hogwarts Legacy  (Read 7009 times)
Alexandros_
Newbie
*
Posts: 4


View Profile
Re: Hogwarts Legacy
« Reply #15 on: February 11, 2023, 12:23 »

how to fix a bug with this texture
Logged
PritornSib
Newbie
*
Posts: 5


View Profile
Re: Hogwarts Legacy
« Reply #16 on: February 11, 2023, 13:34 »

@spiritovod Thank you my friend.
« Last Edit: February 11, 2023, 13:43 by PritornSib » Logged
spiritovod
Global Moderator
Hero Member
*****
Posts: 1844


View Profile
Re: Hogwarts Legacy
« Reply #17 on: February 11, 2023, 17:24 »

@Alexandros: I don't know how you got such result, it works fine here. Maybe it's some kind of user error, but I can't reproduce it, unless textures are explicitly disabled at startup.


* Clipboard01.jpg (89.99 KB, 2550x1242 - viewed 222 times.)
Logged
Alexandros_
Newbie
*
Posts: 4


View Profile
Re: Hogwarts Legacy
« Reply #18 on: February 11, 2023, 18:55 »

@Alexandros: I don't know how you got such result, it works fine here. Maybe it's some kind of user error, but I can't reproduce it, unless textures are explicitly disabled at startup.
i use umodel_acl_2.1
Logged
Puterboy1
Newbie
*
Posts: 6


View Profile
Re: Hogwarts Legacy
« Reply #19 on: February 18, 2023, 03:25 »

What about the sounds? Does it have a .TXT with all the proper names since it uses the wwem audio format?
Logged
Rolfer
Newbie
*
Posts: 3


View Profile
Re: Hogwart's Legacy
« Reply #20 on: February 19, 2023, 16:59 »

The game is using ACL for animations and some virtual textures.

Skeletal meshes and most textures works fine in latest umodel build (1589 at the moment). For proper game support, including animations and static meshes, use specific build from this topic - you need to use game specific override for static meshes to work properly.

Batch operations on the whole game are not recommended, especially for animations, since there are more than 50k animations linked to master skeleton for humanoid characters. Trying to load/export them at once may lead to umodel crash due to system limitations. You can use append option for loading separate folders to current preview.
Hey, I'm using the 1589 umodel_acl_2.1 build. Whenever I try to open any model package I get this (see screenshots). I've also attached the settings I use for the viewer in a screenshot. Any ideas what might be causing this? Thanks! Smiley


* Model-viewer.jpg (46.18 KB, 801x654 - viewed 112 times.)

* CMD-UE.jpg (275.99 KB, 976x509 - viewed 112 times.)

* UE-viewer-settings.jpg (67.69 KB, 498x377 - viewed 142 times.)
Logged
spiritovod
Global Moderator
Hero Member
*****
Posts: 1844


View Profile
Re: Hogwarts Legacy
« Reply #21 on: February 19, 2023, 18:23 »

@Rolfer: I'm actually not sure how you managed to get such result. You can start with checking this post, then check if umodel is not blocked by antivirus for some reason, then do scan on the whole game or at least characters folder (via context menu), after that switch to flat view mode and sort assets by types to ensure you're opening a supported asset. Though even without specific override with just selected appropriate engine (4.27) you should be able to open at least textures.
Logged
Rolfer
Newbie
*
Posts: 3


View Profile
Re: Hogwarts Legacy
« Reply #22 on: February 20, 2023, 00:19 »

@Rolfer: I'm actually not sure how you managed to get such result. You can start with checking this post, then check if umodel is not blocked by antivirus for some reason, then do scan on the whole game or at least characters folder (via context menu), after that switch to flat view mode and sort assets by types to ensure you're opening a supported asset. Though even without specific override with just selected appropriate engine (4.27) you should be able to open at least textures.
Thanks for the suggestions. I installed the DLLs from the official build and turned off all anti-virus and firewalls. Sadly I'm getting the same results. While scanning (both a specific folder like "characters" or the whole game), the scan window says "objects loaded: 0". After the scan is finished the scan window closes and nothing else is shown.
I've also booted Windows up in safe mode and tested it, but even then I get the same result.
Are you using Umodel on the Steam version of the game or another version? (I'm trying to see what would be different on my setup)
Logged
arthurjlorre
Newbie
*
Posts: 2


View Profile
Re: Hogwarts Legacy
« Reply #23 on: February 20, 2023, 01:03 »

@Rolfer: I'm actually not sure how you managed to get such result. You can start with checking this post, then check if umodel is not blocked by antivirus for some reason, then do scan on the whole game or at least characters folder (via context menu), after that switch to flat view mode and sort assets by types to ensure you're opening a supported asset. Though even without specific override with just selected appropriate engine (4.27) you should be able to open at least textures.
Thanks for the suggestions. I installed the DLLs from the official build and turned off all anti-virus and firewalls. Sadly I'm getting the same results. While scanning (both a specific folder like "characters" or the whole game), the scan window says "objects loaded: 0". After the scan is finished the scan window closes and nothing else is shown.
I've also booted Windows up in safe mode and tested it, but even then I get the same result.
Are you using Umodel on the Steam version of the game or another version? (I'm trying to see what would be different on my setup)

I am also getting this error with the same setup.  Checked the forum and couldn't find a fix.
Logged
arthurjlorre
Newbie
*
Posts: 2


View Profile
Re: Hogwart's Legacy
« Reply #24 on: February 20, 2023, 01:22 »

The game is using ACL for animations and some virtual textures.

Skeletal meshes and most textures works fine in latest umodel build (1589 at the moment). For proper game support, including animations and static meshes, use specific build from this topic - you need to use game specific override for static meshes to work properly.

Batch operations on the whole game are not recommended, especially for animations, since there are more than 50k animations linked to master skeleton for humanoid characters. Trying to load/export them at once may lead to umodel crash due to system limitations. You can use append option for loading separate folders to current preview.
Hey, I'm using the 1589 umodel_acl_2.1 build. Whenever I try to open any model package I get this (see screenshots). I've also attached the settings I use for the viewer in a screenshot. Any ideas what might be causing this? Thanks! Smiley

found the solution, delete ~mods folder. So crazy, that it was so simple.
Logged
Rolfer
Newbie
*
Posts: 3


View Profile
Re: Hogwart's Legacy
« Reply #25 on: February 20, 2023, 04:40 »

found the solution, delete ~mods folder. So crazy, that it was so simple.

Omg that worked, thanks so much!
Logged
spiritovod
Global Moderator
Hero Member
*****
Posts: 1844


View Profile
Re: Hogwarts Legacy
« Reply #26 on: February 20, 2023, 21:56 »

@Rolfer, @arthurjlorre: Thanks for reporting the issue. I've updated specific build, it can now open game packages with installed mods as well without renaming or moving mods folder. Also it's now possible to open only folder with mods, though it will not work if the folder has other subfolders or if it's not placed in correct place yet - because for io store packages (utoc/ucas) both umodel and engine itself expect to find global container (global.utoc) in the same folder or Paks folder.
« Last Edit: February 20, 2023, 22:07 by spiritovod » Logged
devilblades
Newbie
*
Posts: 8


View Profile
Re: Hogwarts Legacy
« Reply #27 on: February 25, 2023, 22:18 »

How do we update to latest umodel? on the downloads section I can only get Compiled Oct 22 2022 (build 1589)
Logged
Nymphart
Newbie
*
Posts: 1


View Profile
Re: Hogwarts Legacy
« Reply #28 on: February 26, 2023, 03:21 »

I can't get the models out. Does anyone plan to upload them in t-pose with rig and textures? Or maybe a guide to the process? Ty!  Sad
Logged
spiritovod
Global Moderator
Hero Member
*****
Posts: 1844


View Profile
Re: Hogwarts Legacy
« Reply #29 on: February 26, 2023, 16:55 »

@devilblades: Latest official build is still 1589, but you can check sticked ACL topic (also linked in the second post) and this topic for custom builds, which contains some fixes for particular games, small general improvements and such. Don't look at the builds numbers, rather at compilation date to see if they're outdated or not. But it's always recommended to read game topics first for possible details.
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS