Gildor's Forums

Author Topic: Life is Strange 2  (Read 1523 times)
SurvivorSoB
Newbie
*
Posts: 3


View Profile
Life is Strange 2
« on: May 13, 2019, 00:39 »

There is a problem with LiS 2 animations import





When i try to Ctrl + A, it returns crash

appMalloc:size=-1077129182 (total=257 Mbytes) <- FArray::Empty:-1077129182 x 1 <- TArray::SerializeSimple <- UAnimSequence4::Serialize <- LoadObject:AnimSequence4'PG5_ADD_CarryLamp_MF.PG5_ADD_CarryLamp_MF', pos=2E1C, ver=513/7, game=ue4.17 <- UObject::EndLoad <- LoadWholePackage:PG5_ADD_CarryLamp_MF <- Load:0/300 <- CSkelMeshViewer::FindUE4Animations <- CSkelMeshViewer::AttachAnimSet <- CSkelMeshViewer::ProcessKey <- CUmodelApp::ProcessKey:key=80000061, down=1 <- VisualizerLoop <- Main:umodel_build=1002

Is there can be any fix?

Apart from animation, mesh export works fine
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #1 on: May 13, 2019, 08:42 »

Please send me a few samples (mesh, skeleton, animation)
Logged
SurvivorSoB
Newbie
*
Posts: 3


View Profile
Re: Life is Strange 2
« Reply #2 on: May 13, 2019, 12:21 »

Here

https://drive.google.com/open?id=1lUkt0kzKEMnupaGzpMEP2QqsMfVwuiv-

And some more animation samples

https://drive.google.com/open?id=18cSEBp_JTR2wx1Ntf_5jZZdLP0VioVKi
« Last Edit: May 13, 2019, 12:29 by SurvivorSoB » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #3 on: May 13, 2019, 13:09 »

Done. You didn't provide skeleton files, so animation doesn't work for me, however umodel doesn't crash when loading animations anymore.

Please note that you must override game to "Life is Strange 2" (command line option -game=lis2)

Please let me know if it works with all data available.
Logged
SurvivorSoB
Newbie
*
Posts: 3


View Profile
Re: Life is Strange 2
« Reply #4 on: May 13, 2019, 13:27 »

Yes, it works!



Thank you Grin
« Last Edit: May 13, 2019, 13:31 by SurvivorSoB » Logged
IgelRM
Newbie
*
Posts: 20


View Profile
Re: Life is Strange 2
« Reply #5 on: August 25, 2019, 11:25 »

I'm using the game parameter but I'm still getting the following error while scanning for animations. Noting that the game has been updated as a new episode was released.

File download

Code:
AnimSequence4::Serialize(GetInside_PawnDefault_E2): 5747575 unread bytes
LoadObject:AnimSequence4'GetInside_PawnDefault_E2.GetInside_PawnDefault_E2', pos=1B355, ver=513/7, game=lis2 <- UObject::EndLoad <- LoadWholePackage:GetInside_PawnDefault_E2 <- Load:0/2274 <- CSkelMeshViewer::FindUE4Animations <- CSkelMeshViewer::AttachAnimSet <- CSkelMeshViewer::ProcessKey <- CUmodelApp::ProcessKey:key=80000061, down=1 <- VisualizerLoop <- Main:umodel_build=1068
« Last Edit: August 25, 2019, 12:38 by IgelRM » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #6 on: August 25, 2019, 12:15 »

The file you've sent to me opened with no problems. However I see the difference: in your log, file has version 513/7. In a file which you've uploaded, version is 513/6. There are definitely different files, I think you messed somewhere?
Logged
IgelRM
Newbie
*
Posts: 20


View Profile
Re: Life is Strange 2
« Reply #7 on: August 25, 2019, 12:37 »

Whoops, I think I had uploaded an older file. Edited the link with a just extracted file now.
« Last Edit: August 25, 2019, 13:01 by IgelRM » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #8 on: August 25, 2019, 14:22 »

Please try new umodel. I did an attempt to fix that, however I have just 1 file (with no skeleton, mesh, etc), so I'd like you to check it with all animation assets.
Logged
IgelRM
Newbie
*
Posts: 20


View Profile
Re: Life is Strange 2
« Reply #9 on: August 25, 2019, 15:11 »

Thank you for your effort, it doesn't crash anymore. I tested all the models and animations I could load without an issue.

However, it appears Umodel doesn't detect any animations from episode 4 (the latest one released on 22 Aug).

I uploaded a model, skeleton and animations, please tell if you need something else.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #10 on: August 25, 2019, 15:48 »

Well, I've checked animation data deeper. It seems they've changed compressed animation data format, I can't do anything with that (unless I'll spend a day or two experimenting etc, will not do that).
Logged
IgelRM
Newbie
*
Posts: 20


View Profile
Re: Life is Strange 2
« Reply #11 on: September 14, 2019, 03:01 »

Unsure of this is a LiS2 specific issue, but character models only partially loaded with the latest version of Umodel. I tested this old version and that still works fine. It appears you introduced some issue in between.

Also noticed as a workaround, unloading "LIS2-WindowsNoEditor-Cooked" fixes the issue for some reason.

Screenshot
« Last Edit: September 16, 2019, 08:17 by IgelRM » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #12 on: September 14, 2019, 09:17 »

Try pressing 'M' or 'Ctrl+G' to disable opacity.
Logged
IgelRM
Newbie
*
Posts: 20


View Profile
Re: Life is Strange 2
« Reply #13 on: September 15, 2019, 05:20 »

Whoops, 'Ctrl+G' fixes the issue. Thanks.

Still confused why though since it worked by default before, readme says the shortcut toggles the OpenGL render version.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7816



View Profile WWW
Re: Life is Strange 2
« Reply #14 on: September 15, 2019, 10:21 »

There was a bug in UE Viewer's renderer caused "masked" UE4 materials to be rendered without opacity. I've fixed it less than a month ago.
On the other hand, if you'd send me a model with materials and textures - I could update code which detects opacity channel, and possibly eliminate the problem.
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS