Gildor's Forums

Author Topic: Having some trouble aligning the head/hair for TERA's models  (Read 31463 times)
Shezz
Newbie
*
Posts: 3


View Profile
Having some trouble aligning the head/hair for TERA's models
« on: February 14, 2012, 05:04 »

I've successfully unpacked the .GPKs into .PSKs and can import them into 3ds Max 2010 using the ActorXImporter script, however I run into a bit of a problem trying to follow noazett's instructions (http://www.gildor.org/smf/index.php/topic,478.0.html) on how to align the head.

Aligning Dummy_Hair to Dummy_Face gives something like this:

http://i.imgur.com/Nni4z.png

Which looks correct, I then click "Select and Link" in the top left corner, though apparently this done nothing. I've also tried manually dragging and dropping Dummy_Hair into Dummy_Face at the Scene Explorer so that it acts like a child, but whatever I try to do I get the following when aligning Dummy_Neck to Bip01-Neck:

http://i.imgur.com/LQ9fb.png

It looks like instead of bringing the head up it's bringing the neck down. I've tried selecting Dummy_Neck/Bip01-Neck in reverse order but this is what I always get.

My main objective is to import animations (I tried first in the SkelEdit program I found which was a lot simpler, but unfortunately it doesn't appear to support .PSKs), any ideas on how I can do that?
Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 358


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #1 on: February 14, 2012, 22:14 »

the power of search Wink

http://www.gildor.org/smf/index.php/topic,478.0.html
Logged
Shezz
Newbie
*
Posts: 3


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #2 on: February 15, 2012, 00:10 »

Edit: Nevermind, I've solved the issue with linking the neck and neck bone (I was using Scene Explorer rather than the Select by Name option). Unfortunately loading animations still doesn't move the model, everything is in the right place and the track seems to be looping at the bottom but there's no actual motion. Still, I've seen some progress so I'll spend some time trying to figure out how to get animations working now, thanks for the help.
« Last Edit: February 15, 2012, 01:56 by Shezz » Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 358


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #3 on: February 15, 2012, 02:52 »

an old testvid I did, I have no problem loading animations whatsoever. I remember that head has its separate animations and body another so you can combine if you want

http://vimeo.com/11789521
Logged
Shezz
Newbie
*
Posts: 3


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #4 on: February 15, 2012, 04:59 »

Edit, trying older version of the importer script.
« Last Edit: February 16, 2012, 03:38 by Shezz » Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 358


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #5 on: February 15, 2012, 14:02 »

That is weird. I am doing the same as you. I never choose load all but always doubleclick on one animation. Under there is an option that says something like use from animset, try just clicking some different ones. There is something strange going on and it has to be a small button somewhere Smiley Maybe try and older version of psx importer or something

I will check what my settings are later
Logged
Andrakann
Newbie
*
Posts: 17



View Profile WWW
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #6 on: March 02, 2012, 11:26 »

I have my own workaround for this issue of getting good and animation capable model.
First import all hair models and hide their meshes (except one).
Then unlink "Dummy_neck" bone, because for hairs parent bone is "Dummy_hair" - this is wrong and makes troubles in attaching parts (also causes animation bug).
Next step - clone Dummy_hair bone and rename this cloned bone to "Dummy_face".
Link "Dummy_face" and "Dummy_hair" to "Dummy_neck", so "Dummy_neck" is root parent for skeleton.
Then import face model, hairs must automagically allign to right place, because cloned Dummy_neck from hair bones replaced by Dummy_neck from face ones.
Select and clone "Dummy_face" and "Dummy_neck", then rename to  "Bip01-Head" and "Bip01-Neck" respectively.
Link "Dummy_neck" to "Bip01-Neck", "Dummy_face" to "Bip01-Neck", "Dummy_hair" to "Bip01_Head", so "Bip01_Neck" is root parent at end.
Finally import body, hand, legs parts - head automagically jump in correct place because cloned bones replaced by main skel bones with same names.
Link "Bip01-Neck" to "Bip01-Spine3" (if i remember name correctly) and you have full skeleton with one root, ready for animation.
Then i hide bones, save model, delete body, hands, legs meshes, import another body, hands, legs and "save as.." with new name - etc.
There's an example of final model (specular and normal maps is removed from archive for size reduce), with samples of "run" animations.
Check out skeleton structure, maybe i forget something.
Animations can be added through "File>Merge Animation..." dialog. Open .max file with animation, check "extend frames" box, click lower button between lists of bones and merge. Repeat same steps for face, hair, and attribute animations.

Some tips and tricks:
You can add support for PNG textures to importer:
Code:
-------------------------------------------------------------------------------
-- Loading materials
-------------------------------------------------------------------------------

fn axFindTexture texDir baseName =
(
-- DDS
foundTex = axFindFile texDir (baseName + ".dds") recurse:g_texRecurse
if foundTex != undefined then return foundTex
-- PNG
foundTex = axFindFile texDir (baseName + ".png") recurse:g_texRecurse
if foundTex != undefined then return foundTex
-- TGA
foundTex = axFindFile texDir (baseName + ".tga") recurse:g_texRecurse
-- if foundTex != undefined then return foundTex
-- other formats?
return foundTex
)
I convert all extracted textures from tga to png (with "deep exploration") for lossless size reduce and place textures, meshes and material files to same folder before import, so models already textured in viewport after i import's them.
Head bones have different bind poses and face meshes degrade if you import them one-by-one like i did in example model (i didn't figure out that before i grouped HighElf_F faces - it's horrible), so model can have all hair variants but only one face (
Before batch export hair animations, delete neck bone to prevent bugs.
Models with _H (heavy) uses Class02 and Class04 animations, _L (leather) - Class01, Class03, Class06 and _R (robes) Class05, Class07, Class08.

I hope you can decrypt my runglish here Smiley
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7929



View Profile WWW
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #7 on: March 02, 2012, 11:38 »

I convert all extracted textures from tga to png (with "deep exploration") for lossless size reduce
dds is smaller than tga and lossless too (use "-dds" command line).
Quote
place textures, meshes and material files to same folder before import, so models already textured in viewport after i import's them.
textures are searched recursively (when "recurse" option is checked) starting with "path to materials" directory, so placing everything into a single directory is not necessary, importer should find everything when it is set up correctly.
Logged
Andrakann
Newbie
*
Posts: 17



View Profile WWW
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #8 on: March 02, 2012, 13:10 »

DDS is less compatible with editors/viewers and lossless compressed size about the same as png, in this case i prefer png..
90% screenshots of imported models have no textures, so i think people too lazy to learn how to organize materials and didn't follow yours (good) or my (simple) recommendations, simply leaves them in ..\Textures2D folder in most cases Smiley
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7929



View Profile WWW
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #9 on: March 02, 2012, 13:14 »

90% screenshots of imported models have no textures, so i think people too lazy to learn how to organize materials and didn't follow yours (good) or my (simple) recommendations, simply leaves them in ..\Textures2D folder in most cases Smiley
that's true - I've seen some tutorials where people describing how to map textures in Max (doing the work which can be done by importer automatically Smiley)
Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 358


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #10 on: March 02, 2012, 18:05 »

Tera is really really easy to setup so I don't know what is happening for people Smiley And as you say Gildor, the script almost always fixed all textures for me automatically Smiley I have this viewport shader now that shows models with normal maps etc in max so need to reapply textures but otherwise supernice Smiley
Logged
divStar
Newbie
*
Posts: 7


View Profile
Re: Having some trouble aligning the head/hair for TERA's models
« Reply #11 on: March 07, 2012, 04:29 »

I'm sorry to ask here, but I think this is the most suitable thread of all.
I exported the PSK files using umodel and imported them using ActorX-importer into 3dsmax 2012. I however keep getting problems with textures - I think there's a problem in regards to backface culling. I'm not sure what causes it, but I can't fix it so I'd be happy if someone could give me a hint.

I was able to "force" 2-sided rendering, but then the texture on the outside displayed exactly the same on the inside. I however would like to have simply "black" or "grey" or whatever there is on the inside if possible. The viewport-image I included shows the problem clearly.

Any help is greatly appreciated Smiley. Thank you in advance.

Edit: there's an option at the overall "multi-texture" called "2-sided", but I'd rather have it have "black" inner color than the same texture on the inside as well, though I'll probably be able to live with the 2-sided option if there's no other, better way.

[вложение удалено Администратором]
« Last Edit: March 07, 2012, 04:43 by divStar » Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS