Gildor's Forums

Author Topic: FBX exporter Smoothing Groups problem  (Read 32097 times)
Diegoz77
Newbie
*
Posts: 6


View Profile
FBX exporter Smoothing Groups problem
« on: March 25, 2012, 11:35 »

Hi Gildor
thank you very much for the umodel!!!!! Cheesy

I hope you can help me with a problem I'm having.

In the actor x batch export I select the folder, leave everything to default, and the script creates all the FBX files fine, but when I try to import then in UDK I get a window with a warning saying that no smoothing group information was found in the FBX scene.

I have tried checking the smoothing groups in the fbx export options miself, also unchecked the default fbx settings. I even tweaked the maxscript in the batch so the smoothing groups are always true but I cannot get the smoothing groups to import to UDK version Oct 2010 or the latest version.

i'm using the actor x batch Export 1.01 with actor x import 1.24 in 3ds max 2011 with latest fbx 2012.2.
the latest uModel (March 22 2012)
the files are Mass Effect 2 .pcc  exported to .pskx they are all Static Meshes.

Please Help Me!! Cry

Thank You very much for your time.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7920



View Profile WWW
Re: FBX exporter Smoothing Groups problem
« Reply #1 on: March 25, 2012, 11:54 »

Hi
umodel do not produce smoothing groups information during export.
Logged
Diegoz77
Newbie
*
Posts: 6


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #2 on: March 25, 2012, 12:01 »

The thing is that when I use only the importer I dont get the warning window in UDK.

But when I use the importer with the batch exporter I get the warning and the meshes do not import correctly.

I think that 3ds max creates the smoothing groups when you open the .pskx but i'm not sure.


Please Help!!!

Logged
Gildor
Administrator
Hero Member
*****
Posts: 7920



View Profile WWW
Re: FBX exporter Smoothing Groups problem
« Reply #3 on: March 25, 2012, 12:50 »

What's the problem exactly? This is a warning window, not error. Anything goes wrong when you're closing warning message?
Logged
Diegoz77
Newbie
*
Posts: 6


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #4 on: March 25, 2012, 13:15 »

Thank You for your reply. Smiley

The warning says that UDK needs the appopiate smoothing data so that correct vertex normals can be inferred while importing.

the mesh has black triangles and problems with the U.V.s and the lightning in the level.

The weird thing is that when I use the actor x importer, see the geometry and textures in the viewport and then export the model using file-->export-->.fbx the model imports fine to UDK without any errors.

The problem occurs when the actor x batch exporter is the one that handles the files. Maybe there is a problem in the connection between the two scripts.

Please Help Me,

thanks for your time.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7920



View Profile WWW
Re: FBX exporter Smoothing Groups problem
« Reply #5 on: March 25, 2012, 13:30 »

I have 2 questions.
1) what message UDK prints exactly (so I can find it with UDK)?
2) did you checked Meshes/Smoothing groups option in batch exporter?
Logged
Diegoz77
Newbie
*
Posts: 6


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #6 on: March 25, 2012, 13:56 »

UDK prints exactly:

Warning: No smoothing group information was found in this FBX scene. Please make sure to enable the "Export Smoothing Groups" option in the FBX Exporter plug-in before exporting the file. Even for tools that dont support smoothing groups, the FBX Exporter will generate appropriate smoothing data at export-time so that correct vertex normals can be inferred while importing.

this is printed after choosing the file to import and clicking ok in the window were you enter the name of the package, group, etc.

The smoothing groups option in the batch exporter is activated by default and i have tried turning it off and then on again, I even tweaked the maxscript so it will be true all times, and added a print option to confirm in the maxscript listener that the option is true. Still the vertex normals import incorrectly to UDK

Thanks for your help. Smiley
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7920



View Profile WWW
Re: FBX exporter Smoothing Groups problem
« Reply #7 on: March 25, 2012, 14:16 »

I've checked UDK source code and found that FBX importing code will not generate normals when smoothing groups are missing. Try to use ASE format instead, it's importer is more mature that Autodesk's FBX code.
By the way, is there other people who used batch converter for importing meshes into UDK?
Logged
Diegoz77
Newbie
*
Posts: 6


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #8 on: March 25, 2012, 14:33 »

It's really strange that when I use the actor x importer, see the geometry and textures in the view-port and then export the model using file-->export-->.fbx the model imports fine to UDK without any errors.

The problem, I think, is within the code of the batch exporter, maybe you can check it??

I want to use the actor x batch exporter because the are a lot of .pcc that create a lot of .pskx files in the cookedpc folder and it will take a lot of time to export and check their contents one by one.

The ASE exporter doesnt include the texture files.

Thanks for your help. Smiley
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7920



View Profile WWW
Re: FBX exporter Smoothing Groups problem
« Reply #9 on: March 25, 2012, 20:14 »

The problem, I think, is within the code of the batch exporter, maybe you can check it??
I cannot check this because I have no enough time. You can try to tweak parameters in SetupFBX function (probably there are also other parameters available for tweaking, you can find them in FBX documentation)
Logged
oxyfat
Jr. Member
**
Posts: 51



View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #10 on: March 25, 2012, 21:32 »

Logged
Diegoz77
Newbie
*
Posts: 6


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #11 on: March 25, 2012, 22:08 »

Thanks Gildor for your help, If I manage to tweak the batch exporter I will post it here.

Thanks oxyfat for the reply....

I'm going to try this to see if it helps with static meshes.

Logged
Suhnder
Newbie
*
Posts: 1


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #12 on: April 02, 2012, 08:37 »

I'm having the same exact issue. Works perfectly if I export one-by-one but using the batch exporter results in no smoothing groups. UDK spits out the error for every single object and then imports ugly blocky versions of the geometry. Anyone have more info on this?
Logged
Dijon
Jr. Member
**
Posts: 62


View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #13 on: July 10, 2012, 01:33 »

I use Max 2011 and have this problem as well; if using the Max export menu option, it works perfectly but the batch export reports the error. The work-around that I use is to manually export the first file, and then use the batch export. I don't know why this works but, to date, it has worked for me. YMMV.
Logged
SABREWULF
Newbie
*
Posts: 25



View Profile
Re: FBX exporter Smoothing Groups problem
« Reply #14 on: September 07, 2012, 15:16 »

I have other problem with that exporter..   When i import animation file with the model by actor X importer i have all animations in one model but when i export to fbx t splits all animations  to single files. For example model is satyr and it have 4 animations (when i do Load All) stand run attack death    and when i export it by Batch Exporter it creates 4 files  fbx with a single  animation in every of them   and  i dont know  how to conect it again in  1 file  with  4 animationsbut in FBX format.   Can anyone help me in ths?
« Last Edit: September 07, 2012, 15:17 by SABREWULF » Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS