Gildor's Forums

Author Topic: Exteel models won't export fully  (Read 4571 times)
Dtmech
Newbie
*
Posts: 30


View Profile
Exteel models won't export fully
« on: October 06, 2009, 14:58 »

Hello ,

I try too export some of the Exteel models and the export exports only half of the models or some of the models are missing.

Here is the cmd lines when i export the files.
Code:
E:\Exteel\Animations>umodel -export -md5 GFA_Chest.ukx
Found 17 game files (51 skipped)
Loading package: GFA_Chest.ukx Ver: 126/1002 Names: 422 Exports: 31 Imports: 30
Loading SkeletalMesh CNP010 from package GFA_Chest.ukx
WARNING: package GFT_Mech was not found
Loading SkeletalMesh CEM412 from package GFA_Chest.ukx
...
Loading SkeletalMesh CEH420 from package GFA_Chest.ukx
Loaded in 0.075 sec, 2198 allocs, 4.71 MBytes serialized in 309141 calls.
Exporting objects ...
Exported SkeletalMesh CNP010
...
Exported SkeletalMesh CEM806
duplicate bone NK_06_L_UpperArm, renamed to NK_06_L_UpperArm_2
duplicate bone Bip01_R_Finger11, renamed to Bip01_R_Finger11_2
duplicate bone NK_06_R_UpperArm, renamed to NK_06_R_UpperArm_2
*** ERROR: assertion failed: index >= 0 && index < DataCount

ExportMd5Mesh <- ExportObject:SkeletalMesh'NK_06' <- Main
« Last Edit: October 06, 2009, 15:30 by gildor » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7976



View Profile WWW
Re: Exteel models won't export fully
« Reply #1 on: October 06, 2009, 15:31 »

I need that file (GFA_Chest.ukx) for test.
Logged
Dtmech
Newbie
*
Posts: 30


View Profile
Re: Exteel models won't export fully
« Reply #2 on: October 06, 2009, 15:41 »

Here you go.

http://www.mediafire.com/download.php?dqaaz2y0jwm
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7976



View Profile WWW
Re: Exteel models won't export fully
« Reply #3 on: October 06, 2009, 15:56 »

Thank you for bugreport and test files.
I have fixed that crash. This fix will be available in a new umodel version slightly later (my current build is unstable because of major changes in renderer).
Logged
Dtmech
Newbie
*
Posts: 30


View Profile
Re: Exteel models won't export fully
« Reply #4 on: October 06, 2009, 16:01 »

Thank you for bugreport and test files.
I have fixed that crash. This fix will be available in a new umodel version slightly later (my current build is unstable because of major changes in renderer).

No problem , thanks for the bug fix.

I just couldn't live without those mech models from exteel. Cheesy
Logged
pixellegolas
Sponsor
Sr. Member
*
Posts: 347


View Profile
Re: Exteel models won't export fully
« Reply #5 on: October 06, 2009, 16:04 »

Don't you need the -all command? I haven't tried it but I guess it was a bug because you stated so also gildor Smiley
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS