Gildor's Forums

Author Topic: Error with texture view and with exporting textures  (Read 4047 times)
atomapo
Sponsor
Newbie
*
Posts: 7


View Profile
Error with texture view and with exporting textures
« on: July 11, 2015, 12:40 »

Dear Gildor!

I downloaded the newest version of UE viewer and I think there is a problem with the texture viewer/ extractor function of this software.
I share with you some screenshots about what the problem is, and I hope ,you will find the solution... Please take a look at them in row from 1 to 26.

Thank you! Wink

http://www.mediafire.com/download/jgdueiee5i93afz/Problem_Screenshots.rar
http://www.mediafire.com/download/w1kq2f48kewv86i/.xxx_files.rar
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7995



View Profile WWW
Re: Error with texture view and with exporting textures
« Reply #1 on: July 11, 2015, 14:41 »

Hi!

Thank you for detailed message - I don't need to ask you anything and can perform diagnostics immediately Smiley

I see you have a laptop with ATI/AMD video card integrated. I think this is the cause of bad textures - ATI drivers always had very bad OpenGL support. Try to update your video card drivers, perhaps that will fix the problem.

If that'll not help, or you're already having latest drivers installed - try to switch to "basic" OpenGL mode with Ctrl+G key. This will disable uploading of BC7 textures to video card and decompress them in memory instead. Also I believe, if you'll press "Ctrl+X" when viewing "bad" texture, you'll get exported TGA file and it will look nice.

About "gamma issues" and missing texture parts. Try "FastStone Image browser", you'll see the correct texture. I see that developers has included some information into the alpha channel of diffuse texture. And this is definitely not a translucency of the model, it's something different (I hope this is not just garabge). So, when you use this texture, you should disable or remove alpha channel. You're seeing a bit dim colors because you're seeing background through this texture.
Logged
atomapo
Sponsor
Newbie
*
Posts: 7


View Profile
Re: Error with texture view and with exporting textures
« Reply #2 on: July 11, 2015, 15:54 »

Wow, you are awesome! Thanks for the fast info Gildor.
I tested the mesh+ bone export, that's works very good!
I have the "omega" driver for my AMD card. I think it's the latest.


So the situation is that: I shawed you 3 type of errors.

The first one: In fact, with the Mortal Kombat X characters is not exist, texture EXTRACTION is works like charm!!
Only the VIEW mode is strange by this game, but the most important thing is the correct export. All right.

The other two:
-  Where sould I switch to "basic" OpenGL mode? In UE viewer or in my AMD Catalyst control center?
-  Where should I disable alpha chanel for the texture correction?

So I press ctrl-X, and extract the mesh and the textures to the UmodelExport folder.
Than I imported the "psk" to 3ds max with ActorX importer. I see the bones, the mesh, but can't see the textures.

How to import the texture files to 3ds max? How to install them into the character mesh? /for this question, have you got any tutorial information, or an older writing somewhere here? or can you help me how to add the extracted textures?

-Is there any solution for the "programfilesx86 don't let me extract anything to these subfolder"- protected folder structure problem?

Sorry for the large amount of questions, but this is my learning day  Grin and I realise that this software is amazing.

Thanks for the reply!
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7995



View Profile WWW
Re: Error with texture view and with exporting textures
« Reply #3 on: July 11, 2015, 16:07 »

-  Where sould I switch to "basic" OpenGL mode? In UE viewer or in my AMD Catalyst control center?
In UModel, while viewing, press Ctrl+G key. Then load something different, for example with pressing PgDn key (because UModel will not reload texture when rendering mode changed).
Quote
-  Where should I disable alpha chanel for the texture correction?
I don't know, depends on program you're using. For example, you can load image into some editor as RGBA (32-bit) and save it as RGB (24-bit).
Quote
So I press ctrl-X, and extract the mesh and the textures to the UmodelExport folder.
Than I imported the "psk" to 3ds max with ActorX importer. I see the bones, the mesh, but can't see the textures.

How to import the texture files to 3ds max? How to install them into the character mesh? /for this question, have you got any tutorial information, or an older writing somewhere here? or can you help me how to add the extracted textures?
Check UModel's readme file! It has all links. And I think you didn't see the UModel's page on this site, otherwise you'd not ask this question Smiley
Quote
-Is there any solution for the "programfilesx86 don't let me extract anything to these subfolder"- protected folder structure problem?
You don't need to extract there - extract to any folder. But if you have a game already installed (doesn't matter to Program Files or somewhere else, but with ENGLISH characters in directory names!) - just point UModel to that location, you don't need to copy data somewhere else.
Logged
atomapo
Sponsor
Newbie
*
Posts: 7


View Profile
Re: Error with texture view and with exporting textures
« Reply #4 on: July 11, 2015, 16:41 »

I tested the FastStone image viewer, and works pretty good! The exported textures are Hd, and the original quality.
Noesis was not the best tool for TGA viewing....

Censequence: Everything is all right now with the UE viewer software!

Thanks for everything! I donated you some money for your help and patience!
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS