Gildor's Forums

Author Topic: Fortnite  (Read 280316 times)
InFuseD
Newbie
*
Posts: 9


View Profile
Re: Fortnite
« Reply #1725 on: June 14, 2021, 01:26 »

ive been trying to export diamond hanz backpack on /Game/Accessories/FORT_Backpacks/Backpack_MED_Day_Trader
but im getting unversioned error even using ue4.27, someone know how to avoid this ?


... And yes the umodel is updated
« Last Edit: June 14, 2021, 01:28 by InFuseD » Logged
Juso3D
Moderator
Hero Member
*****
Posts: 910


Welcome to Gildor Forums


View Profile
Re: Fortnite
« Reply #1726 on: June 14, 2021, 09:43 »

It seems like all Static Meshes are broken at this stage.
Logged

Blender + Linux User Here.
core-i
Newbie
*
Posts: 1


View Profile
Re: Fortnite
« Reply #1727 on: June 23, 2021, 17:32 »

Hi,
I need some help, please.
I want to export "Female Splash Specialist" model and textures. I exported body, head models and textures but head is no hair??!!
I looked every paks folder, google etc. but I didn't find anywhere. Smiley
Do you help me where I can find it.
Thanks.



* ss.png (302.29 KB, 585x700 - viewed 142 times.)
« Last Edit: June 23, 2021, 17:35 by core-i » Logged
Harry123
Newbie
*
Posts: 3


View Profile
Re: Fortnite
« Reply #1728 on: June 27, 2021, 08:07 »

I get:


USkeletalMesh4::ConvertMesh <- USkeletalMesh4::Serialize <- LoadObject: SkeletalMesh4'F_MED_Blackwidow_Body.F_MED_Blackwidow_Body', pos=34496, ver=522/0, game=ue4.26 <- UObject::EndLoad <- LoadWholePackage: /Game/Characters/Player/Female/Medium/Bodies/F_MED_Blackwidow/Meshes/F_MED_Blackwidow_Body.uasset <- ExportPackages <- CUmodelApp::ShowPackageUI <- Main: umodel_build=1556

when trying to export a mesh.
Logged
Juso3D
Moderator
Hero Member
*****
Posts: 910


Welcome to Gildor Forums


View Profile
Re: Fortnite
« Reply #1729 on: June 27, 2021, 11:32 »

Hi,
I need some help, please.
I want to export "Female Splash Specialist" model and textures. I exported body, head models and textures but head is no hair??!!
I looked every paks folder, google etc. but I didn't find anywhere. Smiley
Do you help me where I can find it.
Thanks.



Check for Faceacc for some hair meshes.

F_MED_Bunny_Fashion_PER_Faceacc



I get:


USkeletalMesh4::ConvertMesh <- USkeletalMesh4::Serialize <- LoadObject: SkeletalMesh4'F_MED_Blackwidow_Body.F_MED_Blackwidow_Body', pos=34496, ver=522/0, game=ue4.26 <- UObject::EndLoad <- LoadWholePackage: /Game/Characters/Player/Female/Medium/Bodies/F_MED_Blackwidow/Meshes/F_MED_Blackwidow_Body.uasset <- ExportPackages <- CUmodelApp::ShowPackageUI <- Main: umodel_build=1556

when trying to export a mesh.

Fortnite uses UE4.27
« Last Edit: June 27, 2021, 12:25 by Blenux » Logged

Blender + Linux User Here.
Harry123
Newbie
*
Posts: 3


View Profile
Re: Fortnite
« Reply #1730 on: June 28, 2021, 07:31 »

Thanks @Blenux
Logged
spiritovod
Global Moderator
Hero Member
*****
Posts: 1932


View Profile
Re: Fortnite
« Reply #1731 on: July 04, 2021, 17:09 »

Here is specific umodel build with temporary fix for static meshes (link) - use 4.27 override option.

Update: Apparently, it also fixes some animations.

Update 2: It's better to disable animations at umodel startup window, because a lot of them are using ACL compression now, which is not supported in umodel yet. For animations use latest Fmodel version.


* Clipboard10.jpg (142.92 KB, 2539x1232 - viewed 144 times.)
« Last Edit: September 30, 2021, 18:00 by spiritovod » Logged
Имечко
Newbie
*
Posts: 3


View Profile
Re: Fortnite
« Reply #1732 on: July 07, 2021, 16:25 »

Here is specific umodel build with temporary fix for static meshes (link) - use 4.27 override option.
It's not work for me (including your tree from the screenshot). Did it work for someone?
« Last Edit: July 07, 2021, 16:31 by Имечко » Logged
nanojin
Newbie
*
Posts: 3


A nano.


View Profile
Issue - Memory Allocation Error
« Reply #1733 on: July 10, 2021, 19:58 »

Hello,

So I tried posting over on github about an issue I believed to be fairly technical. I did not expect the issue to be immediately swatted down.

Anyway, I am posting here to (hopefully) alleviate further moderation. Though, I still believe the issue is technical and deserves some introspection, however brief.

Link to the closed issue: https://github.com/gildor2/UEViewer/issues/229

I have continued to work the original angle which prompted raising the issue, which is likely just one of many, and I believe a pattern has emerged where I think someone with a deeper level of knowledge can understand or to help explain.

Assets that seem to feature "facial" animations or "poses" or something to that tune seem to throw bad memory allocation errors.
Additionally, "sounds" seem to raise a varied sort of issues as well.
Also, an idea that comes to mind would be some sort of functionality that detects and skips errors? Is it possible?


So far I have tested these assets, the errors arising in order:

Code:
/Game/Animation/Game/MainPlayer/Emotes/BreakfastCoffeeDance/Emote_BreakfastCoffeeDance_CMM.uasset
/Game/Characters/Player/Female/Medium/Heads/F_MED_Faux_Head/Meshes/Female_Medium_Faux_Head_Facial_Poses.uasset
/Game/Characters/Player/Female/Medium/Bodies/F_MED_Lady_Atlantis/Meshes/Parts/Female_Medium_Lady_Atlantis_Head_Facial_Poses.uasset


And this asset, in the effort to extract a specific emote and sound:
The error: "Unversioned properties problem"

Code:
/Game/Athena/Sounds/Weapons/Pickaxes/AssembleR/PickAxe_Assemble_R_Impact_01.uasset
/Game/Athena/Sounds/Emotes/Breakfast_Coffee/Emote_Breakfast_Coffee_Loop.uasset

If this is a common issue, my apologies!

My most recent error:

Code:
Memory: bad allocation size -40265352 bytes
appMalloc: size=-40265352 (total=158 Mbytes) <- FArray::Empty: 1073182583 x 72 <- HandleTArray <- CTypeInfo::SerializeUnversionedProperties4: Type=UAnimSequence4 <- UObject::Serialize <- UAnimSequenceBase::Serialize <- UAnimSequence4::Serialize <- LoadObject: AnimSequence4'Female_Medium_Lady_Atlantis_Head_Facial_Poses.Female_Medium_Lady_Atlantis_Head_Facial_Poses', pos=991, ver=523/0, game=ue4.27 <- UObject::EndLoad <- LoadWholePackage: /Game/Characters/Player/Female/Medium/Bodies/F_MED_Lady_Atlantis/Meshes/Parts/Female_Medium_Lady_Atlantis_Head_Facial_Poses.uasset <- ExportPackages <- CUmodelApp::ShowPackageUI <- Main: umodel_build=1562

I am actively researching the issue, as it is new to me, and it seems that people who ask questions aren't exactly welcomed here so I'll tread carefully. Additionally there seems to be an extensive amount of ground to cover (and to learn) as the scope of UE Viewer covers an extensive number of games, and so to claim the issue is specific to Fortnite would ultimately be unfair.

However, in saying this, figuring out exactly what has gone wrong or whether the issue is due to bad configuration (my fault), improper program settings (my fault), unresolved/unsupported/unplanned features (program-specific), or just bugs (unlikely), requires an extensive amount of specialized knowledge that isn't easily resolved or simply knowable. This is especially true when Fortnite receives a major update, such as the recent new season, as that can raise a ton of unknown issues and reduces compatibility.

Just know that this one does not seek to intellectually harm anyone due to their ignorance of the subject matter.

--

- Yours truly,
- A student of computer science
« Last Edit: July 10, 2021, 20:07 by nanojin » Logged
Gildor
Administrator
Hero Member
*****
Posts: 7973



View Profile WWW
Re: Fortnite
« Reply #1734 on: July 11, 2021, 10:00 »

Hi,
I've closed your issue on github because "standard" UModel is not intended to work with recent Fortnite due to some problems. However if you'd check THIS thread, you'd notice the solution:
Here is specific umodel build with temporary fix for static meshes (link) - use 4.27 override option.
Logged
nanojin
Newbie
*
Posts: 3


A nano.


View Profile
Re: Fortnite
« Reply #1735 on: July 11, 2021, 11:07 »

That's a fix for static meshes? I don't think I had any issues with static meshes. So I didn't believe that portion of the conversation was relevant to the issue I'd noticed with animations, facial expressions, and sound. (I don't know what CMM is, but it's part of an emote so I assume it deals with animation.)

Does the temporary fix address anything I've said so far?
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7973



View Profile WWW
Re: Fortnite
« Reply #1736 on: July 11, 2021, 11:11 »

I have no idea what was fixed there, but at least nobody said that anything doesn't work.
Logged
nanojin
Newbie
*
Posts: 3


A nano.


View Profile
Re: Fortnite
« Reply #1737 on: July 11, 2021, 20:30 »

Hmm, I could also say that no one has said it does work! Also Thanks for clarifying what umodel isn't intended to do!

So, you're saying the fix fixes the issues I'm having with poses and sound? Unless what I'm missing is that the StaticMesh issue is responsible for those issues as well. Hmm, so it's a data structure problem? I think I see...
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7973



View Profile WWW
Re: Fortnite
« Reply #1738 on: July 12, 2021, 08:53 »

Technically, the problem is with "unversioned properties". This is a complex data structure, and inserting or removing just 1 property to the object breaks things. Unversioned properties appeared in UE4.26, and Fortnite was in sync with that data. In UE4.27 things changed, and I've updated UModel for that. However, in Fortnite things changed in a DIFFERENT way - things which exists in Fortnite are missed in UE4.27 and vice versa. I'll resolve issues when Fortnite will be updated to include UE4.27 changes, so a workaround build could be used until that.

Regarding sounds, Epic has changed things I think in UE4.25, so they WON'T work in UModel.
Logged
spiritovod
Global Moderator
Hero Member
*****
Posts: 1932


View Profile
Re: Fortnite
« Reply #1739 on: July 12, 2021, 17:03 »

@Gildor: It seems like a different issue. I've checked it and mentioned animations works fine in official 1556 build, but crashes with unversioned properties error in 1562. For example, open /Game/Characters/Player/Female/Medium/Heads/F_MED_Faux_Head/Meshes/Female_Medium_Faux_Head.uasset and add /Game/Characters/Player/Female/Medium/Heads/F_MED_Faux_Head/Meshes/Female_Medium_Faux_Head_Facial_Poses.uasset animation to it.

@nanojin: The mentioned specific build, posted above, should indeed fix those errors with animations (though for different reason). As for sounds, it's better to use Fmodel for them, because in umodel this feature is optional anyway and like Gildor explained above, it doesn't work in latest UE4 games due to updated format (and it didn't work with wwise audio even before that).
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS