Gildor's Forums

Author Topic: A noob question  (Read 54 times)
ocarinas
Newbie
*
Posts: 5


View Profile
A noob question
« on: September 21, 2020, 09:55 »

Hello, first I'm pretty new to this 3D thingies, and I've got a noob question.
Why do some animations appear like this?
https://imgur.com/a/9GLvCer
And how do I fix it?

Thanks in advance.
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7772



View Profile WWW
Re: A noob question
« Reply #1 on: September 21, 2020, 09:59 »

What's wrong with the picture?
Logged
ocarinas
Newbie
*
Posts: 5


View Profile
Re: A noob question
« Reply #2 on: September 21, 2020, 10:47 »

Why does the monster look like they are wearing a rainbow knit sweater?
https://imgur.com/zTiRq8j
Is this normal or am I misunderstand something
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7772



View Profile WWW
Re: A noob question
« Reply #3 on: September 21, 2020, 10:51 »

This is normal. When UModel can't render some material, or when material has missing textures (e.g. you provided ukx, but umodel can't find utx) - you'll see this "default texture".
Logged
ocarinas
Newbie
*
Posts: 5


View Profile
Re: A noob question
« Reply #4 on: September 21, 2020, 10:53 »

I see, thank you for clarifying.
Logged
ocarinas
Newbie
*
Posts: 5


View Profile
Re: A noob question
« Reply #5 on: September 21, 2020, 13:19 »

Sorry, just one more question.
I tried opening those missing textured models from 3 different game version (C4, Interlude, and Hi5, they are clean without modding), and results are still the same.
Does UModel just can't render them or is something wrong from my end? Does this also happen to anyone too? I need a confirmation, so that I can move on.

Thanks again
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7772



View Profile WWW
Re: A noob question
« Reply #6 on: September 21, 2020, 13:29 »

The things you're describing (well, not "describing" but rather "talking about") could be caused by different problems, so it's preferred way if you'd record a video showing your actions for opening a game, viewport, and log window.
Logged
ocarinas
Newbie
*
Posts: 5


View Profile
Re: A noob question
« Reply #7 on: September 21, 2020, 13:37 »

Found these warnings on log window.
Code:
Loading package: systextures/MFighter.utx Ver: 123/27 Names: 574 Exports: 530 Imports: 23 Game: 200005
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m000_m00_bh from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m000_m00_ah from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m001_l from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m001_u from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m001_g from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m001_b from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh FFighter_m009_m00_bh from package animations/Fighter.ukx
Loading SkeletalMesh MFighter_m012_b from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m012_g from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh
Loading SkeletalMesh MFighter_m012_l from package animations/Fighter.ukx
WARNING: bad LOD#0 mesh, switching to base
ERROR: bad base mesh

and a TONS of the same warning...
I'll record a vid later, I have to go having a dinner with my family soon.

Sorry for the trouble.

EDIT: I found couple of people who encountered the same problem as me.
https://www.gildor.org/smf/index.php?topic=2194.0
https://github.com/gildor2/UEViewer/issues/149
http://www.runestorm.com/forums/viewtopic.php?f=4&t=77928

I'll move on now. Thanks for helping me out, Gildor
« Last Edit: September 21, 2020, 17:07 by ocarinas » Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS