Gildor's Forums

Author Topic: is there any problem that using animation data for assimp?  (Read 51 times)
moonkg9992050
Newbie
*
Posts: 2


View Profile
is there any problem that using animation data for assimp?
« on: October 20, 2021, 04:25 »

i'm trying to animate my model with using assimp. The model and animation downloaded from mixamo work normally, but when the extracted data with ue viewer is applied, it works normally when only the model is applied
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7997



View Profile WWW
Re: is there any problem that using animation data for assimp?
« Reply #1 on: October 20, 2021, 10:51 »

Just to exclude possible user-level errors:

1. Did you import both psk and psa into assimp?
2. Are model and animation matched? They probably have different skeletons.
3. Did you try viewing the same animation on the same model in UE Viewer itself?
Logged
moonkg9992050
Newbie
*
Posts: 2


View Profile
Re: is there any problem that using animation data for assimp?
« Reply #2 on: October 20, 2021, 11:01 »

Just to exclude possible user-level errors:

1. Did you import both psk and psa into assimp?
2. Are model and animation matched? They probably have different skeletons.
3. Did you try viewing the same animation on the same model in UE Viewer itself?

i converted psk and psa to fbx via 3ds max and i checked animation work normally in 3ds max but when i run it my project it becomes like that i posted
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7997



View Profile WWW
Re: is there any problem that using animation data for assimp?
« Reply #3 on: October 20, 2021, 11:04 »

Definitely not an umodel issue then. AssImp has custom Fbx loading code, it is not based on FbxSdk, therefore you might expect lots of bugs there.
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS