Gildor's Forums

Author Topic: Sea of Thieves  (Read 9424 times)
Gildor
Administrator
Hero Member
*****
Posts: 7713



View Profile WWW
Re: Sea of Thieves
« Reply #105 on: July 23, 2020, 14:46 »

Hopefully I've fixed Sea of Thieves support. All pak files which I have are fully openable/exportable.

Interestingly, the issue with oodle decompressor which I mentioned before, wasn't with oodle actually. There was LZ4 block which has first 2 bytes matching with oodle block, so wrong decompressor was used.
Logged
Dummy
Sponsor
Newbie
*
Posts: 12


View Profile
Re: Sea of Thieves
« Reply #106 on: July 23, 2020, 18:35 »

I'm testing it right now. I'll let you know.
Logged
Dummy
Sponsor
Newbie
*
Posts: 12


View Profile
Re: Sea of Thieves
« Reply #107 on: July 24, 2020, 00:46 »

I can confirm that it works. I can't find a mesh that doesn't. The textures don't seem to be applied to models correctly and for some reason have very intense emissive glow but thats not really important. Thank you so much for your hard work Gildor!
Logged
Mandalorian
Sponsor
Jr. Member
*
Posts: 40



View Profile
Re: Sea of Thieves
« Reply #108 on: July 24, 2020, 20:19 »

Thanks Gildor!
Logged
ElGoblino
Newbie
*
Posts: 5


View Profile
Re: Sea of Thieves
« Reply #109 on: July 26, 2020, 11:55 »

Thanks for the hard work, appreciate it.

One thing, is it normal that I cannot seem to open animation data?  I get errors like this when I try it with practically any uasset in the animations area of the game:

Logged
Grendor
Jr. Member
**
Posts: 64


View Profile
Re: Sea of Thieves
« Reply #110 on: July 26, 2020, 20:53 »

Yeah, animations don't work, so you might want to change the listing on the compatibility table. Also I got an error with one of the npc meshes. It is as follows.

Code:
Memory: bad allocation size -4 bytes
appMalloc:size=-4 (total=236 Mbytes) <- FArray::Empty:-1 x 4 <- TArray::SerializeSimple <- SerializeBulkArray <- FMultisizeIndexContainer<< <- FStaticLODModel4<< <- TArray::Serialize:0/5 <- USkeletalMesh4::Serialize <- LoadObject:SkeletalMesh4'npc_ghost_crew02.npc_ghost_crew02', pos=B1A02, ver=483/20, game=sot <- UObject::EndLoad <- LoadWholePackage:/Game/Models/Characters/NPCs/npc_ghost_crew/npc_ghost_crew_02/npc_ghost_crew02.uasset <- ExportPackages <- CUmodelApp::ShowPackageUI <- Main:umodel_build=1339
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7713



View Profile WWW
Re: Sea of Thieves
« Reply #111 on: July 26, 2020, 22:14 »

I have 4Gb of pak files. They have 20+ animations. All are loadable. I have no other data to test.
Logged
rroobboo
Full Member
***
Posts: 119


I am the Great Cornholio! Hhh...Hhh...


View Profile
Re: Sea of Thieves
« Reply #112 on: July 27, 2020, 11:59 »

You need to extract .pak files with quickBMS(script in attached files) and then animations work
AES Key: 0x37A0BC3DC2E01D9EB4923CA266A5701F56A4802347F07927FC3FC25C93B31B50
Bad News: you will need to put that key 866 times in quickBMS window  Shocked

* unreal_tournament_4_0.4.23.1a_sot.bms (9.2 KB - downloaded 20 times.)
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7713



View Profile WWW
Re: Sea of Thieves
« Reply #113 on: July 27, 2020, 12:45 »

It shouldn't matter if pak is extracted or not - UModel is intended to work with this game's pak files.
Logged
rroobboo
Full Member
***
Posts: 119


I am the Great Cornholio! Hhh...Hhh...


View Profile
Re: Sea of Thieves
« Reply #114 on: July 27, 2020, 12:59 »

It doesn't Gildor, gives me this error

******** Loading object AnimSequence4'1st_action_repairidle_2h.1st_action_repairidle_2h' ********

ERROR: AnimSequence4::Serialize(1st_action_repairidle_2h): 1111 unread bytes
LoadObject:AnimSequence4'1st_action_repairidle_2h.1st_action_repairidle_2h', pos=10A0, ver=483/20, game=sot <- UObject::EndLoad <- LoadWholePackage:/Game/Animation/FirstPerson/action/repair/1st_action_repairidle_2h.uasset <- Load:0/10215 <- CSkelMeshViewer::FindUE4Animations <- CSkelMeshViewer::AttachAnimSet <- CSkelMeshViewer::ProcessKey <- CUmodelApp::ProcessKey:key=80000061, down=1 <- VisualizerLoop <- Main:umodel_build=1339
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7713



View Profile WWW
Re: Sea of Thieves
« Reply #115 on: July 27, 2020, 13:17 »

And if you'll extract it with QuickBMS - it's ok??
If so, could you please send me 2 versions of files: extracted with BMS and extracted ("saved") with UModel, please?
Logged
ElGoblino
Newbie
*
Posts: 5


View Profile
Re: Sea of Thieves
« Reply #116 on: July 27, 2020, 14:26 »

Uploaded both versions of an example animation. Both throw the same error when opened as the one I posted earlier.

* 3rd_action_repairidle_fb (QuickBMS).uasset (38.83 KB - downloaded 10 times.)
* 3rd_action_repairidle_fb (umodel).uasset (38.83 KB - downloaded 12 times.)
Logged
Gildor
Administrator
Hero Member
*****
Posts: 7713



View Profile WWW
Re: Sea of Thieves
« Reply #117 on: July 27, 2020, 14:29 »

They are the same, so I suppose
You need to extract .pak files with quickBMS(script in attached files) and then animations work
is not true?
Logged
ElGoblino
Newbie
*
Posts: 5


View Profile
Re: Sea of Thieves
« Reply #118 on: July 27, 2020, 14:31 »

They are the same, so I suppose
You need to extract .pak files with quickBMS(script in attached files) and then animations work
is not true?

I used his script too instead of my own and it made no difference. So far I haven't been able to find an animation that I can actually open. Can you provide an example of one that you've tested just to make sure that it's not on my end?
Logged
rroobboo
Full Member
***
Posts: 119


I am the Great Cornholio! Hhh...Hhh...


View Profile
Re: Sea of Thieves
« Reply #119 on: July 27, 2020, 15:05 »

is not true?
It will take some time. last Friday I did it and it was working, now I'm gonna extract all files again to be absolutely sure if it works
Logged
Jump to:  

Powered by SMF | SMF © 2006-2009, Simple Machines LLC
Leviathan design by Bloc | XHTML | CSS